Bug 842021 - Do not work right after installation
Do not work right after installation
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nsd (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Wouters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-20 17:55 EDT by Michael Scherer
Modified: 2012-08-21 14:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-21 14:33:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Scherer 2012-07-20 17:55:49 EDT
Description of problem:

The bug is similar to #755198.

Since /var/run/nsd is not created right after the installation of the package, nsd do not start correctly ( ie, it start, but systemctl do not finish ). once I create the directory, all is well.

To test, just install nsd, check that there is no /var/run/nsd directory, try to start it ( after adding a zone ), and see that systemctl start nsd.service never finish.

Creating the missing directory in /var/run fix the issue for me.
Comment 1 Paul Wouters 2012-07-23 17:39:40 EDT
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=4324501

Fixed in rawhide
Comment 2 Fedora Update System 2012-07-27 16:11:30 EDT
nsd-3.2.13-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/nsd-3.2.13-1.el6
Comment 3 Fedora Update System 2012-07-27 18:06:07 EDT
Package nsd-3.2.13-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing nsd-3.2.13-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-6531/nsd-3.2.13-1.el6
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-08-21 14:33:51 EDT
nsd-3.2.13-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.