Bug 842117 - [rhevm-dwh] - Installer - Failed to Upgrade existing History DB
[rhevm-dwh] - Installer - Failed to Upgrade existing History DB
Status: CLOSED DUPLICATE of bug 844667
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Yaniv Lavi
David Botzer
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-22 05:28 EDT by David Botzer
Modified: 2016-02-10 14:18 EST (History)
7 users (show)

See Also:
Fixed In Version: SI13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-06 07:08:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dwh-upgrade-histDB (6.85 KB, application/octet-stream)
2012-07-22 05:28 EDT, David Botzer
no flags Details

  None (edit)
Description David Botzer 2012-07-22 05:28:05 EDT
Created attachment 599574 [details]
dwh-upgrade-histDB

Description of problem:
Remote Setup - when running ovirt-engine-dwh-setup, it Failed to Upgrade existing History DB

Version-Release number of selected component (if applicable):
3.1/si11

How reproducible:
Always

Steps to Reproduce:
1.prepare remote db server
2.Install rhevm+dwh & run SETUP for both (select in rhevm-setup "remote")
3.Verify History db is created on remote server
4.Rerun ovirt-engine-dwh-setup
  
Actual results:
Fails to upgrade existing history db

Expected results:
Should do one of the following:
    A. Upgrade db correctly
    B. Should advise a db is already found, and finish installation correctly   
       (Without upgrade)

Additional info:
2012-07-22 12:11:56::ERROR::decorators::27::root:: Traceback (most recent call last):
  File "/usr/share/ovirt-engine-dwh/decorators.py", line 20, in wrapped_f
    output = f(*args)
  File "/usr/bin/ovirt-engine-dwh-setup", line 88, in upgradeDB
    output, rc = utils.execExternalCmd(cmd, True, "Error while trying to upgrade ovirt_engine_history DB")
  File "/usr/share/ovirt-engine-dwh/common_utils.py", line 173, in execExternalCmd
    raise Exception(msg)
Exception: Error while trying to upgrade ovirt_engine_history DB

2012-07-22 12:11:56::ERROR::ovirt-engine-dwh-setup::247::root:: Exception caught!
2012-07-22 12:11:56::ERROR::ovirt-engine-dwh-setup::248::root:: Traceback (most recent call last):
  File "/usr/bin/ovirt-engine-dwh-setup", line 231, in main
    upgradeDB(db_dict)
  File "/usr/share/ovirt-engine-dwh/decorators.py", line 28, in wrapped_f
    raise Exception(instance)
Exception: Error while trying to upgrade ovirt_engine_history DB
Comment 1 Yaniv Lavi 2012-07-26 05:34:07 EDT
Fixed in patch:
http://gerrit.ovirt.org/#/c/6642/


Yaniv
Comment 2 David Botzer 2012-08-06 05:38:15 EDT
Not Fixed for si13.1
Reopen
Comment 3 Yaniv Lavi 2012-08-06 07:08:33 EDT

*** This bug has been marked as a duplicate of bug 844667 ***

Note You need to log in before you can comment on or make changes to this bug.