Bug 842136 - [nova][RFE][Resize|Migrate][preformance] avoid ssh/scp on shared nova-lib dir.
[nova][RFE][Resize|Migrate][preformance] avoid ssh/scp on shared nova-lib dir.
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
1.0 (Essex)
Unspecified Unspecified
medium Severity medium
: Upstream M3
: 4.0
Assigned To: Brent Eagles
Yogev Rabl
storage
: CodeChange, FutureFeature, Improvement
Depends On:
Blocks: RHOS40RFE
  Show dependency treegraph
 
Reported: 2012-07-22 09:41 EDT by David Naori
Modified: 2016-04-26 18:25 EDT (History)
10 users (show)

See Also:
Fixed In Version: openstack-nova-2013.2-0.8.b2.el6ost
Doc Type: Enhancement
Doc Text:
With this update, migration operations will not attempt to copy data when the specified source and destination are the same filesystem location. This is due to the consideration that recopying the data would be inefficient and may risk corrupting the file.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 18:53:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1177247 None None None Never

  None (edit)
Description David Naori 2012-07-22 09:41:36 EDT
Description of problem:
nova should avoid ssh/scp when Resizing/Migrating to remote host with shared nova-lib directory

it can use check_shared_storage_test_file to indicate if its on shared storage or not and act differently.

log:
ssh 10.35.77.4 mkdir -p /mnt/nova-lib/instances/instance-00000174 from (pid=14823) execute /
usr/lib/python2.6/site-packages/nova/utils.py:220

scp /mnt/nova-lib/instances/instance-00000174_resize/disk_rbase 10.35.77.4:/mnt/nova-lib/instances/instance-00000174/disk from (pid=14823) execute /usr/lib/python2.6/site-packages/nova/utils.py:220

Version-Release number of selected component (if applicable):
openstack-nova-2012.1.1-4.el6.noarch
Comment 1 Pádraig Brady 2012-07-23 05:26:21 EDT
Yep should look into this in detail.
rsync might mitigate somewhat, though that might be foiled by the
mv ... ..._resize operation done on the directory.
Comment 2 Nikola Dipanov 2012-12-13 10:54:37 EST
Moving this to Grizzly as we have
Comment 3 Nikola Dipanov 2012-12-13 10:55:33 EST
... shipped Folsom and we won't be adding any features to it.
Comment 5 Brent Eagles 2013-09-05 16:29:06 EDT
It looks like the fix landed in havana-1 and was backported to Grizzly (d34d4cacf7b20f72c67f7873dcf2c372abc60ecd).

Change-Id: Ie9decedd373c000211c171df64e1e96fe78e5081
Comment 11 errata-xmlrpc 2013-12-19 18:53:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.