Bug 842149 - [ovirt-engine] null pointer exception on SPM Start (IrsSpmStartFailedException)
[ovirt-engine] null pointer exception on SPM Start (IrsSpmStartFailedException)
Status: CLOSED DUPLICATE of bug 845310
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity urgent
: ---
: 3.1.0
Assigned To: Tal Nisan
Haim
storage
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-22 10:47 EDT by Haim
Modified: 2016-02-10 11:33 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-12 12:53:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine all vdsm log (2.08 MB, application/x-tar)
2012-08-08 13:05 EDT, Haim
no flags Details

  None (edit)
Description Haim 2012-07-22 10:47:27 EDT
Description of problem:


after failure in attachStorageDomain, engine sent spmStop to the current spm, and then spmStart to the second one in pool, though it failed with empty null pointer exception, and pool cannot be activated.


2012-07-22 20:46:16,611 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.IrsBrokerCommand] (QuartzScheduler_Worker-62) [5d52ee12] SpmStatus on vds 2fc87f7c-d404-11e1-bd4b-001a4a16970e: Free
2012-07-22 20:46:16,618 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.IrsBrokerCommand] (QuartzScheduler_Worker-62) [5d52ee12] starting spm on vds nott-vds1.qa.lab.tlv.redhat.com, storage pool myPool, prevId 2, LVER 0
2012-07-22 20:46:16,619 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SpmStartVDSCommand] (QuartzScheduler_Worker-62) [5d52ee12] START, SpmStartVDSCommand(vdsId = 36c461e8-d403-11e1-93d8-001a4a16970e, storagePoolId = 947784d8-d402-11e1-9b0a-001a4a16970e, prevId=2, prevLVER=0, storagePoolFormatType=null, recoveryMode=Manual, SCSIFencing=false), log id: 27a6e011
2012-07-22 20:46:16,619 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerCommand] (QuartzScheduler_Worker-62) [5d52ee12] Failed in SpmStartVDS method, for vds: nott-vds1.qa.lab.tlv.redhat.com; host: nott-vds1.qa.lab.tlv.redhat.com
2012-07-22 20:46:16,619 ERROR [org.ovirt.engine.core.vdsbroker.VDSCommandBase] (QuartzScheduler_Worker-62) [5d52ee12] Command SpmStartVDS execution failed. Exception: NullPointerException: 
2012-07-22 20:46:16,619 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SpmStartVDSCommand] (QuartzScheduler_Worker-62) [5d52ee12] FINISH, SpmStartVDSCommand, log id: 27a6e011
2012-07-22 20:46:16,621 INFO  [org.ovirt.engine.core.bll.storage.SetStoragePoolStatusCommand] (QuartzScheduler_Worker-62) [3cc0906d] Running command: SetStoragePoolStatusCommand internal: true. Entities affected :  ID: 947784d8-d402-11e1-9b0a-001a4a16970e Type: StoragePool
2012-07-22 20:46:16,628 ERROR [org.ovirt.engine.core.vdsbroker.irsbroker.IrsBrokerCommand] (QuartzScheduler_Worker-62) [3cc0906d] IrsBroker::Failed::GetStoragePoolInfoVDS due to: IrsSpmStartFailedException: IRSGenericException: IRSErrorException: SpmStart failed
Comment 2 Haim 2012-07-23 05:25:51 EDT
please note that except getSpmStatus, nothing is sent to vdsm, the above log contains all the transaction.
Comment 3 Ayal Baron 2012-08-01 09:13:27 EDT
vdsm log?
engine full log?
Comment 4 Haim 2012-08-01 09:21:31 EDT
(In reply to comment #3)
> vdsm log?
> engine full log?

the above log is all I got; nothing on vdsm log was relevant, and the above output contains all the transaction (threads) from engine.log.
Comment 5 Ayal Baron 2012-08-08 05:46:50 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > vdsm log?
> > engine full log?
> 
> the above log is all I got; nothing on vdsm log was relevant, and the above
> output contains all the transaction (threads) from engine.log.

Please *always* attach logs even if you're sure they're irrelevant.
We'll try to figure it out from this but without logs it's problematic.
Comment 6 Haim 2012-08-08 13:05:18 EDT
Created attachment 603080 [details]
engine all vdsm log

just because you asked so nicely. 
this is a general problem introduced lately which related to the fact engine send getStoragePoolInfo and doesn't like what he gets, in the current case (attached logs), getStoragePoolInfo returns the following:

[root@nott-vds1 ~]# vdsClient -s 0 getStoragePoolInfo b3bcc6da-e075-11e1-828e-001a4a16970e 
        name = Default
        isoprefix = 
        pool_status = connected
        lver = 0
        domains = 0efa73b6-fa78-4bbe-ba03-2451f8efcff4:Active
        master_uuid = 0efa73b6-fa78-4bbe-ba03-2451f8efcff4
        version = 3
        spm_id = -1
        type = ISCSI
        master_ver = 1
        0efa73b6-fa78-4bbe-ba03-2451f8efcff4 = {'status': 'Active', 'diskfree': '48049946624', 'alerts': [], 'disktotal': '53284438016'}

engine is having a problem with pool name which not correlated with data-center name updated in db, fails with NPE, and doesn't even send the spmStart command to vdsm.
Comment 7 Haim 2012-08-12 12:53:46 EDT

*** This bug has been marked as a duplicate of bug 845310 ***

Note You need to log in before you can comment on or make changes to this bug.