Bug 842153 - spacewalk-hostname-rename fails on pgsql
spacewalk-hostname-rename fails on pgsql
Status: CLOSED DUPLICATE of bug 809444
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
1.7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Mráka
Red Hat Satellite QA List
:
Depends On:
Blocks: space18
  Show dependency treegraph
 
Reported: 2012-07-22 10:50 EDT by Mohammed Arafa
Modified: 2012-11-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-22 16:41:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohammed Arafa 2012-07-22 10:50:37 EDT
Description of problem:

[root@spacewalk bin]# spacewalk-hostname-rename 192.168.1.11
Validating IP ... OK
=============================================
hostname: spacewalk.marafa.vm
ip: 192.168.1.11
=============================================
Stopping rhn-satellite services ... OK
Testing DB connection ... psql:<stdin>:1: ERROR:  syntax error at or near "off"
LINE 1: set feed off;
                 ^
FAILED
Your database isn't running.
Fix the problem and run /usr/bin/spacewalk-hostname-rename again


Version-Release number of selected component (if applicable):
1.7

How reproducible:
everytime

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
spacewalk server down

Expected results:
spacewalk accepts new hostname

Additional info:
looked at the script, line 389 only supports oracle 
searched for psql is script .. no mention of it
Comment 1 Jan Pazdziora 2012-07-22 16:41:45 EDT

*** This bug has been marked as a duplicate of bug 809444 ***

Note You need to log in before you can comment on or make changes to this bug.