Bug 842181 - perl-SOAP-Lite drops provides for perl(IO::SessionSet) and perl(IO::SessionData) in rawhide version.
perl-SOAP-Lite drops provides for perl(IO::SessionSet) and perl(IO::Session...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-SOAP-Lite (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Šabata
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-22 17:14 EDT by Richard Shaw
Modified: 2012-08-02 11:57 EDT (History)
2 users (show)

See Also:
Fixed In Version: perl-SOAP-Lite-0.715-2.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-02 11:54:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Shaw 2012-07-22 17:14:05 EDT
Description of problem:
When trying to build MythTV in rawhide I ran across the following error on the build server.

DEBUG util.py:257:  Error: Package: perl-SOAP-Transport-TCP-0.715-6.fc18.noarch (fedora-rawhide)
DEBUG util.py:257:             Requires: perl(IO::SessionSet)
DEBUG util.py:257:  Error: Package: perl-SOAP-Transport-TCP-0.715-6.fc18.noarch (fedora-rawhide)
DEBUG util.py:257:             Requires: perl(IO::SessionData)


Version-Release number of selected component (if applicable):
perl-SOAP-Lite-0.715-1.fc18.noarch


Additional info:

The F17 version seems to provide these perl moduels. I'm not sure if this is a packaging error or an upstream change but nothing else currently appears to provide these modules.
Comment 1 Petr Šabata 2012-07-23 03:55:52 EDT
Yes, 0.715 (upstream) no longer provides those modules.
I've hit the same issue with SOAP::Transport::TCP and filed RT#78489 [1] for it.  The upstream maintainer is the same person.

So far this seems intentional but I'd wait for some comments from him.

[1] https://rt.cpan.org/Public/Bug/Display.html?id=78489
Comment 2 Richard Shaw 2012-07-23 09:26:31 EDT
Is it safe for me to assume then that you'll be waiting to hear from upstream before pushing this version to the stable branches?
Comment 3 Petr Šabata 2012-07-23 09:55:32 EDT
(In reply to comment #2)
> Is it safe for me to assume then that you'll be waiting to hear from
> upstream before pushing this version to the stable branches?

Yes;  this is just a Rawhide thing.
Comment 4 Richard Shaw 2012-07-30 22:31:47 EDT
Hmm... 10 days with no activity on the cpan bug tracker... Not a good sign.
Comment 5 Petr Šabata 2012-08-01 10:03:16 EDT
I've mailed Martin directly now.

I suspect this change wasn't intentional and will include the modules from 0.714 if he doesn't respond in near future.
Comment 6 Petr Šabata 2012-08-02 11:54:24 EDT
Upstream confirmed those were removed unintentionally and will be added again in the next release.  I've added the latest versions (0.714) of those to the current (perl-SOAP-Lite-0.715-2.fc18) package for the time being.
Comment 7 Richard Shaw 2012-08-02 11:57:44 EDT
Thanks for following up!

Note You need to log in before you can comment on or make changes to this bug.