Bug 842195 - yum snapshots security context problem in btrfs /home
yum snapshots security context problem in btrfs /home
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Eric Paris
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-22 22:14 EDT by A. Mani
Modified: 2013-08-01 12:25 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 12:25:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A. Mani 2012-07-22 22:14:05 EDT
Description of problem:
After uninstalling yum snapshots in encrypted btrfs /home,
the directories in /home are not removable by superuser or user.
chown has no effect due to context: system_u:object_r: s0

Version-Release number of selected component (if applicable):


How reproducible:
0 selinux enforcing
1. install F17 with encrypted btrfs /home with 10 GB data (say)
2. keep on updating over a few days.
3. Many snapshots occupying considerable space would result.
4. The contents may be deletable by superuser, but not the directories
5. Uninstall the yum snapshot plugin
6. system_u:object_r: s0






Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Walsh 2012-07-23 10:47:51 EDT
Have you tried to run restorecon -R -v /home?  Can you try in permissive mode if this does not work.  This looks like you have somehow gotten a bad label into brtfs, this could be a bug in btrfs also.
Comment 2 A. Mani 2012-07-23 12:09:18 EDT
Yes, that does not change the context and even if I do it from outside (Scientific Linux-6.2). 

ls -idZ 
drwxr-xr-x. <username> 1000 system_u:object_r:home_root_t:s0 /media/abc/yum_20120630071356
Comment 3 Daniel Walsh 2012-07-23 13:30:40 EDT
I have no idea how those labels got onto the file system.  Very strange.
Comment 4 Need Real Name 2012-07-25 17:40:56 EDT
just checking: you've tried deleting using

btrfs su del /media/abc/yum_20120630071356

..?
Comment 5 A. Mani 2012-07-26 22:19:57 EDT
Yes, I  tried btrfs subvolume delete.
Btw, this partition was from F16 and was created much earlier. So the bug should be duplicated first.
Comment 6 Daniel Walsh 2012-07-31 11:48:52 EDT
Seems like a kernel issue to me.
Comment 7 Dave Jones 2013-05-15 14:55:12 EDT
is this still a problem in current release ?
Comment 8 Fedora End Of Life 2013-07-04 01:23:25 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 9 Fedora End Of Life 2013-08-01 12:25:56 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.