Bug 842221 - Slow git pull on larger projects with 1.7.10.4-1.fc17
Slow git pull on larger projects with 1.7.10.4-1.fc17
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: git (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Wright
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-23 03:45 EDT by Milan Crha
Modified: 2013-01-10 06:03 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-25 05:39:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Crha 2012-07-23 03:45:38 EDT
I have a clone of git://git.gnome.org/evolution which I "git pull" couple times a day, usually in the morning. It's a writeable checkout, but I do not expect it making any difference.

The thing is that if I "git pull" with gitk-1.7.10.4-1.fc17.noarch then it takes too long, sometimes close to a minute, sometimes I'm not patient enough and I Ctrl+C it, as it seems stuck. If I downgrade to git-1.7.10.1-1.fc17.x86_64, then the "git pull" is significantly faster, it takes about 15 seconds.
Comment 1 Milan Crha 2012-07-25 05:39:17 EDT
Hrm, seems to be server-side issue. I'm sorry for a noise.

Note You need to log in before you can comment on or make changes to this bug.