Bug 842272 - include-passwd option can't worked when using domdisplay.
include-passwd option can't worked when using domdisplay.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Martin Kletzander
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-23 06:06 EDT by zhe peng
Modified: 2013-02-21 02:19 EST (History)
8 users (show)

See Also:
Fixed In Version: libvirt-0.10.0-0rc0.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 02:19:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhe peng 2012-07-23 06:06:03 EDT
Description of problem:
--include-passwd option can't worked when using domdisplay

Version-Release number of selected component (if applicable):
libvirt-0.9.13-3.el6.x86_64

How reproducible:
always

Steps to Reproduce:
Steps to Reproduce:
1. prepare a guest with spice graphic
2. setup spice ssl env.
3. give a password to spice
#virsh dumpxml $guest --security-info
  ......
   <graphics type='spice' port='5900' tlsPort='5907' autoport='yes' listen='0.0.0.0' keymap='en-us' passwd='redhat' passwdValidTo='2022-02-27T19:46:10' connected='disconnect'>
      <listen type='address' address='0.0.0.0'/>
      <channel name='main' mode='secure'/>
      <channel name='inputs' mode='secure'/>
    </graphics>
  ......
4. use virt-viewer to connect guest
# remote-viewer spice://$IP?port=5900\&tls-port=5907 --spice-host-subject="C=IL,L=Raanana,O=Red Hat,CN=my server" --spice-ca-file='/etc/pki/libvirt-spice/ca-cert.pem'
worked well with input correct password
5. using domdisplay to show spice URI
# virsh domdisplay $guest --include-password


Actual results:
spice://localhost?port=5900&tls-port=5907
no password shown up in URI.

Expect result:

should providing the password for the SPICE channel.



additional :
i check the patch,
virAsprintf(&xpath, "string(/domain/devices/graphics"
                     "[ type='%s']/@passwd)", scheme[iter]);

maybe should be:
virAsprintf(&xpath, "string(/domain/devices/graphics[ type='%s']"
                     "/@passwd)", scheme[iter]);
Comment 2 Martin Kletzander 2012-07-23 14:58:40 EDT
Patches has been posted upstream:

https://www.redhat.com/archives/libvir-list/2012-July/msg01235.html
Comment 3 Martin Kletzander 2012-07-25 05:09:02 EDT
Patches have been commited upstream, moving to POST:

commit 8101d434336a2ad89f6d2dbfbff54f79b3eb6890
Author: Martin Kletzander <mkletzan@redhat.com>
Date:   Tue Jul 24 16:00:14 2012 +0200

    virsh: fixed domdisplay command
Comment 7 zhpeng 2012-08-06 21:56:13 EDT
I'm sorry for that i made a mistake...

test it with libvirt-0.10.0-0rc0.el6:

virsh # domdisplay rhel63q
spice://localhost?port=5900&tls-port=5901
virsh # domdisplay rhel63q --include-password 
spice://localhost?port=5900&tls-port=5901&password=redhat

So this is verified.
Comment 8 errata-xmlrpc 2013-02-21 02:19:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHSA-2013-0276.html

Note You need to log in before you can comment on or make changes to this bug.