Bug 842273 - [abrt] evolution-3.4.3-2.1.fc17: camel_ews_folder_get_message: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
[abrt] evolution-3.4.3-2.1.fc17: camel_ews_folder_get_message: Process /usr/b...
Status: CLOSED DUPLICATE of bug 761609
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:b48eac0a2ee66df799372066e3e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-23 06:07 EDT by Mikhail
Modified: 2012-07-24 11:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-24 11:06:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (90.56 KB, text/plain)
2012-07-23 06:07 EDT, Mikhail
no flags Details
File: gconf_subtree (10.75 KB, text/plain)
2012-07-23 06:07 EDT, Mikhail
no flags Details
File: xsession_errors (5.13 KB, text/plain)
2012-07-23 06:07 EDT, Mikhail
no flags Details
File: maps (79.89 KB, text/plain)
2012-07-23 06:07 EDT, Mikhail
no flags Details
File: dso_list (27.54 KB, text/plain)
2012-07-23 06:07 EDT, Mikhail
no flags Details
File: build_ids (11.21 KB, text/plain)
2012-07-23 06:08 EDT, Mikhail
no flags Details

  None (edit)
Description Mikhail 2012-07-23 06:07:32 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        evolution
core_backtrace: cac4a4c28a673cee360a6e2ce145ac93946b4d9a 0x9d66 camel_ews_folder_get_message libcamelews.so -
crash_function: camel_ews_folder_get_message
executable:     /usr/bin/evolution
kernel:         3.4.6-2.fc17.i686.PAE
pid:            1540
pwd:            /home/mikhail
time:           Пн. 23 июля 2012 14:13:40
uid:            1000
username:       mikhail

backtrace:      Text file, 92738 bytes
build_ids:      Text file, 11480 bytes
dso_list:       Text file, 28200 bytes
gconf_subtree:  Text file, 11006 bytes
maps:           Text file, 81803 bytes
xsession_errors: Text file, 5255 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/mikhail/2

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=telecon17l.afbank.ru
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=928ad44a76a7008e0260558b00000016-1343016952.696196-2118857789
:QTDIR=/usr/lib/qt-3.3
:GNOME_KEYRING_CONTROL=/run/user/mikhail/keyring-w3x2h9
:QTINC=/usr/lib/qt-3.3/include
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:USER=mikhail
:USERNAME=mikhail
:MAIL=/var/spool/mail/mikhail
:PATH=/usr/lib/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/mikhail/.local/bin:/home/mikhail/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/mikhail
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1054
:LANG=en_US.UTF-8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/mikhail
:SHLVL=1
:LOGNAME=mikhail
:QTLIB=/usr/lib/qt-3.3/lib
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-Ma5NvXS7Nt,guid=d911e7e570eb4657f79c5cb900000034
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/mikhail
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-mikhail-cTv5HF/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1059,unix/unix:/tmp/.ICE-unix/1059
:GPG_AGENT_INFO=/run/user/mikhail/keyring-w3x2h9/gpg:0:1
:SSH_AUTH_SOCK=/run/user/mikhail/keyring-w3x2h9/ssh
:LC_TIME=ru_RU.utf8
:LC_NUMERIC=ru_RU.utf8
:LC_MONETARY=ru_RU.utf8
:LC_MEASUREMENT=ru_RU.utf8
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/evolution.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=1540
:DESKTOP_STARTUP_ID=gnome-shell-1289-telecon17l.afbank.ru-evolution-0_TIME82283

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 23949                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       23949                23949                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/mikhail/.xsession-errors
:pos:	1712885
:flags:	02002
:2:/home/mikhail/.xsession-errors
:pos:	1712885
:flags:	02002
:3:socket:[24538]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:socket:[24543]
:pos:	0
:flags:	02004002
:6:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:7:socket:[24545]
:pos:	0
:flags:	02004002
:8:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:9:socket:[24838]
:pos:	0
:flags:	02004002
:10:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:11:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:12:socket:[24872]
:pos:	0
:flags:	02004002
:13:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:14:socket:[24873]
:pos:	0
:flags:	02004002
:15:/home/mikhail/.pki/nssdb/cert9.db
:pos:	2048
:flags:	02100002
:16:/var/tmp/etilqs_SBhxBDy5m9zqvYk (deleted)
:pos:	28
:flags:	02100002
:17:/var/tmp/etilqs_ORYKiMiY3D6fYX4 (deleted)
:pos:	2056
:flags:	02500002
:18:/var/tmp/etilqs_4lQoPt2YWqPFBsK (deleted)
:pos:	2048
:flags:	02500002
:19:/home/mikhail/.pki/nssdb/key4.db
:pos:	40
:flags:	02100002
:20:/var/tmp/etilqs_9Vff1ElQ38fhfvY (deleted)
:pos:	28
:flags:	02100002
:21:/var/tmp/etilqs_FtaEnZNaH0PZ5Uk (deleted)
:pos:	2056
:flags:	02500002
:22:/var/tmp/etilqs_ocggpeptApV2jBz (deleted)
:pos:	2048
:flags:	02500002
:23:/etc/pki/nssdb/cert9.db
:pos:	2048
:flags:	02100000
:24:/var/tmp/etilqs_zctpVMziTNjlPPk (deleted)
:pos:	28
:flags:	02100002
:25:/var/tmp/etilqs_UgSU9xvABKqEE61 (deleted)
:pos:	2048
:flags:	02500002
:26:/etc/pki/nssdb/key4.db
:pos:	40
:flags:	02100000
:27:/var/tmp/etilqs_88EXxoTCH6KcY18 (deleted)
:pos:	28
:flags:	02100002
:28:/var/tmp/etilqs_Fz1U71aLFnxBWal (deleted)
:pos:	2048
:flags:	02500002
:29:/home/mikhail/.local/share/evolution/mail/local/folders.db
:pos:	38912
:flags:	02100002
:30:/home/mikhail/.local/share/evolution/mail/vfolder/folders.db
:pos:	40
:flags:	02100002
:31:/home/mikhail/.cache/evolution/mail/1333120619.4756.0@telecon17l.afbank.ru/folders.db
:pos:	15426560
:flags:	02100002
:32:anon_inode:inotify
:pos:	0
:flags:	02004000
:33:/home/mikhail/.cache/evolution/mail/1333516140.1463.1@telecon17l.afbank.ru/folders.db
:pos:	40
:flags:	02100002
:34:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:35:/dev/urandom
:pos:	0
:flags:	02000000
:36:socket:[3669301]
:pos:	0
:flags:	02004002
:37:socket:[1079560]
:pos:	0
:flags:	02004002
:38:socket:[26272]
:pos:	0
:flags:	02000002
:39:socket:[1302692]
:pos:	0
:flags:	02004002
:40:/home/mikhail/.local/share/gvfs-metadata/home (deleted)
:pos:	0
:flags:	0100000
:41:/home/mikhail/.local/share/gvfs-metadata/home-edaba09b.log (deleted)
:pos:	0
:flags:	0100000
:42:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:43:socket:[3670876]
:pos:	0
:flags:	02004002
:44:/home/mikhail/.cache/evolution/mail/1333120619.4756.0@telecon17l.afbank.ru/folders.db-journal
:pos:	12
:flags:	02100002

smolt_data:
:
:
:General
:=================================
:UUID: 24b82623-fdb0-487f-b726-0d6b01472500
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: i686
:BogoMIPS: 4787.78
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Duo CPU     E4600  @ 2.40GHz
:CPU Stepping: 13
:CPU Family: 6
:CPU Model Num: 15
:Number of CPUs: 2
:CPU Speed: 2400
:System Memory: 3010
:System Swap: 16382
:Vendor: Unknown
:System:  
:Form factor: Unknown
:Kernel: 3.4.6-2.fc17.i686.PAE
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10672:32902:20298) pci, None, HOST/PCI, 82Q35 Express DRAM Controller
:(32902:10673:32902:20298) pci, pcieport, PCI/PCI, 82Q35 Express PCI Express Root Port
:(4523:24833:4523:24833) pci, pata_marvell, STORAGE, 88SE6101/6102 single-port PATA133 interface
:(32902:10544:32902:20298) pci, i801_smbus, SERIAL, 82801I (ICH9 Family) SMBus Controller
:(32902:10530:32902:20298) pci, ahci, STORAGE, 82801IR/IO/IH (ICH9R/DO/DH) 6 port SATA AHCI Controller
:(32902:10516:32902:20298) pci, None, PCI/ISA, 82801IO (ICH9DO) LPC Interface Controller
:(32902:4285:32902:1) pci, e1000e, ETHERNET, 82566DM-2 Gigabit Network Connection
:(32902:9294:32902:20298) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:10549:32902:20298) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:10548:32902:20298) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(32902:10553:32902:20298) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10550:32902:20298) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(32902:10554:32902:20298) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10556:32902:20298) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:(32902:10564:32902:10564) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 3
:(32902:10566:32902:10566) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 4
:(32902:10560:32902:10560) pci, pcieport, PCI/PCI, Optiplex 755
:(32902:10562:32902:10562) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 2
:(32902:10676:32902:20298) pci, None, SIMPLE, 82Q35 Express MEI Controller
:(32902:10568:32902:10568) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 5
:(32902:10558:32902:18) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(32902:10551:32902:20298) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10552:32902:20298) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:(4098:43664:5963:43664) pci, snd_hda_intel, MULTIMEDIA, N/A
:(4098:26457:5963:57747) pci, radeon, VIDEO, NI Turks [AMD Radeon HD 6500]
:(4545:22545:4545:22545) pci, firewire_ohci, FIREWIRE, FW322/323
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda1 / ext4 4096 4096 5112289 2187288 2136095 1286144 950107 950107
:/dev/sda5 /home ext4 4096 4096 27764613 1551864 161477 6955008 6851371 6851371
:

var_log_messages:
:Jul 23 10:06:37 telecon17l abrt[16437]: File '/usr/bin/evolution' seems to be deleted
:Jul 23 10:09:22 telecon17l abrt[16437]: Saved core dump of pid 15398 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-07-23-10:06:37-15398 (628281344 bytes)
:Jul 23 14:13:49 telecon17l abrt[9589]: Saved core dump of pid 1540 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-07-23-14:13:40-1540 (238604288 bytes)
Comment 1 Mikhail 2012-07-23 06:07:41 EDT
Created attachment 599743 [details]
File: backtrace
Comment 2 Mikhail 2012-07-23 06:07:44 EDT
Created attachment 599744 [details]
File: gconf_subtree
Comment 3 Mikhail 2012-07-23 06:07:47 EDT
Created attachment 599745 [details]
File: xsession_errors
Comment 4 Mikhail 2012-07-23 06:07:52 EDT
Created attachment 599746 [details]
File: maps
Comment 5 Mikhail 2012-07-23 06:07:57 EDT
Created attachment 599747 [details]
File: dso_list
Comment 6 Mikhail 2012-07-23 06:08:01 EDT
Created attachment 599748 [details]
File: build_ids
Comment 7 Milan Crha 2012-07-24 11:06:03 EDT
Thanks for a bug report. I see this is evoltuion-ews-3.4.3-1.9, thus basically the latest one we have (the change in 1.10 might be unrelated). I see in the backtrace that you were downloading a message (where it also crashed), and that one folder was refreshing its content, and you also moved to other message in message list, which invoked cancel request on the message fetch. I'm not sure how much the cancel request is related to this crash. Nonetheless, the crash is more or less obvious, the 'items' variable is NULL, while the crash line dereferences it.

I found this filled already, thus I added a notice to related upstream bug report. Please see it for further updates.

*** This bug has been marked as a duplicate of bug 761609 ***

Note You need to log in before you can comment on or make changes to this bug.