Bug 842276 - stat shows 0% for newly added locales
stat shows 0% for newly added locales
Status: CLOSED WORKSFORME
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.6.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: zanata-dev-internal
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-23 06:32 EDT by Parag Nemade
Modified: 2012-10-02 18:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-02 18:53:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Parag Nemade 2012-07-23 06:32:23 EDT
Description of problem:
Today, Few new locales added in zanata server which relaxes the need to write locale mapping in zanata.xml file. But, when pushed po files for these locales, message statistics showing 0%.

Problematic locales: zh-CN, zh-TW, sr, ta, pt.

Version-Release number of selected component (if applicable):
zanata python client version: 1.3.8, zanata server API version: 1.6.0


How reproducible:
always

Steps to Reproduce:
1.zanata push --push-trans  --lang zh-CN --disable-ssl-cert
2. check server for stat of this file. Observe it as 0%
3. zanata pull --lang zh-CN

  
Actual results:
pushed and pulled files looks same but still statistics is not calculated.

Expected results:
fix to show correct stat for these locales.

Additional info:
Comment 1 Runa Bhattacharjee 2012-07-30 07:58:45 EDT
Assigning to Zanata Dev team for evaluation.
Comment 2 Sean Flanigan 2012-07-30 21:54:48 EDT
Stats currently look okay for https://translate.zanata.org/zanata/iteration/view/iok/f18-1

How soon after the upload did you check the stats?
Comment 3 Parag Nemade 2012-07-30 23:27:42 EDT
I was checking till next 1-2 days since my commit and I saw stat showing 0%. Just suspect will non-logged interface shows stale stat? in case I might have logged out and still checking the stats.

I tried to reproduce this but failed. So, looks push is working fine now.

Note You need to log in before you can comment on or make changes to this bug.