Bug 842277 - "some assemblies will not be launched provider_name provider is not available" error displayed when try to launch any instance after getting an instance in create failed state
"some assemblies will not be launched provider_name provider is not available...
Status: CLOSED WORKSFORME
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Jan Provaznik
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-23 06:40 EDT by pushpesh sharma
Modified: 2014-08-04 18:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-23 07:35:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
all logs (12.08 MB, application/x-tar)
2012-07-23 07:19 EDT, pushpesh sharma
no flags Details

  None (edit)
Description pushpesh sharma 2012-07-23 06:40:17 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Build and push any simple image (in my case rhel6.2)
2.Create a deployable from this image
3.Launch overview page is shown all paramter matching 
4.On the aeolus-host stop deltacloud core service
5.Launch the deployable from it,deployment fails and now in create_failed state(as expected).
6.start the deltacloud-core service again
7.deleted the instance.
8.try to launch instance from this deploable results in 
"some assemblies will not be launched provider_name provider is not available"
 is displayed.
9.Any new instance launch from any existing deployment in any catalog results in same error.
10 aeolus-service restart doesnt help either,new deployment created also results in this.

 

Additional info:

[root@qeblade29 ~]# rpm -qa|grep aeolus
aeolus-configure-2.7.0-0.20120712224728gitcc8302d.fc16.noarch
rubygem-aeolus-cli-0.6.0-0.20120712224735gite2a391a.fc16.noarch
aeolus-conductor-0.11.0-0.20120713030022git8c99e02.fc16.noarch
aeolus-conductor-daemons-0.11.0-0.20120713030022git8c99e02.fc16.noarch
aeolus-all-0.11.0-0.20120713030022git8c99e02.fc16.noarch
aeolus-conductor-doc-0.11.0-0.20120713030022git8c99e02.fc16.noarch
aeolus-conductor-devel-0.11.0-0.20120713030022git8c99e02.fc16.noarch
rubygem-aeolus-image-0.5.0-1.fc16.noarch
Comment 1 pushpesh sharma 2012-07-23 07:19:15 EDT
Created attachment 599757 [details]
all logs
Comment 2 pushpesh sharma 2012-07-23 08:31:25 EDT
Works fine after some time(i tried after 2 hrs,may start wokring earlier) and few restart of deltacloud-core service.Might be some latency issue. Please update if this is expected. As it didnt works atleast 20 mins or so after the situation.
Comment 5 Jan Provaznik 2012-08-23 04:00:19 EDT
Conductor (dbomatic) checks periodically every 5 minutes availability of providers and realms. If a provider is not accessible, it's marked as unavailable. If the provider becomes accessible again in some of next checks, it marked back as available. Information about unvailability is displayed on providers show page, you can also enforce accessibility check on this page by clicking on "Test connection".

So if you stopped dc-core, then it's possible that for next ~5 minutes the provider was not available.

Can you please retest this and check:
- if info about unavailability is displayed on provider show page
- if the provider becomes available again after 5-6 minutes since you start dc-core again -> then instance launch on this provider should work again too
Comment 6 pushpesh sharma 2012-08-23 07:35:00 EDT
I tried steps mentioned in Comment#5.Yes it seems there is only ~5 min latency now.This is acceptable.Marking as closed as it workes for me now.

Note You need to log in before you can comment on or make changes to this bug.