Bug 842279 - Incomplete command line in UCD-SNMP-MIB::extCommand
Summary: Incomplete command line in UCD-SNMP-MIB::extCommand
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: net-snmp
Version: 6.3
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: ---
Assignee: Jan Safranek
QA Contact: Dalibor Pospíšil
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-07-23 10:49 UTC by Karel Srot
Modified: 2013-02-21 10:27 UTC (History)
1 user (show)

Fixed In Version: net-snmp-5.5-44.el6
Doc Type: Bug Fix
Doc Text:
The MIB definition of UCD-SNMP-MIB::extCommand describes it as "The command line to be executed." Previously, implementation of UCD-SNMP-MIB::extCommand in snmpd daemon reported only name of the executable, missing all other command line parameters. In this update, the UCD-SNMP-MIB::extCommand implementation is fixed and snmpd shows full command line.
Clone Of:
Environment:
Last Closed: 2013-02-21 10:27:20 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch (3.10 KB, patch)
2012-09-10 11:29 UTC, Jan Safranek
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0421 normal SHIPPED_LIVE net-snmp bug fix and enhancement update 2013-02-20 20:49:35 UTC

Description Karel Srot 2012-07-23 10:49:06 UTC
Description of problem:

net-snmp-5.5-41.el6_3.1:
UCD-SNMP-MIB::extCommand.1 = STRING: /bin/echo

while RHEL5 does
net-snmp-5.3.2.2-18.el5:
UCD-SNMP-MIB::extCommand.1 = STRING: /bin/echo message 1


Steps to reproduce:
1. define script entry in snmpd.conf
2. snmpwalk...

Comment 2 Jan Safranek 2012-09-10 11:29:14 UTC
Created attachment 611408 [details]
Patch

Adding patch so it does not get lost, usptream has code freeze.

Comment 3 RHEL Program Management 2012-09-10 11:39:32 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 8 errata-xmlrpc 2013-02-21 10:27:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0421.html


Note You need to log in before you can comment on or make changes to this bug.