Bug 84230 - finds/requires not determining correct library to require
finds/requires not determining correct library to require
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-13 13:04 EST by R P Herrold
Modified: 2007-04-18 12:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-23 11:41:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attenpted install with --vv (6.56 KB, text/plain)
2003-02-13 13:06 EST, R P Herrold
no flags Details
built time finds and provides stanza (4.36 KB, text/plain)
2003-02-13 13:07 EST, R P Herrold
no flags Details

  None (edit)
Description R P Herrold 2003-02-13 13:04:02 EST
Source RPM evidencing the issue at:

ftp://ftp.owlriver.com/pub/local/ORC/wxPythonGTK-py2.2/
which was pulled and rebuyilt, hands off, from the reference site on an RHL 8.0
host, essentially 'stock' with all updates.

The resulting binary RPMs install directly on RHL 8.0, with no --nodeps required

---------------------

Pull and build on Phoebe 2 clean install


Checking for unpackaged file(s): /usr/lib/rpm/check-files
/var/tmp/wxPythonGTK-py2.2-buildroot
Wrote: /home/herrold/redhat/SRPMS/wxPythonGTK-py2.2-2.4.0.2-2.src.rpm
Wrote: /home/herrold/redhat/RPMS/i386/wxPythonGTK-py2.2-2.4.0.2-2.i386.rpm
Wrote: /home/herrold/redhat/RPMS/i386/wxPythonGTK-devel-2.4.0.2-2.i386.rpm
Wrote:
/home/herrold/redhat/RPMS/i386/wxPythonGTK-py2.2-debuginfo-2.4.0.2-2.i386.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.43918
+ umask 022
+ cd /home/herrold/redhat/BUILD
+ cd wxPythonSrc-2.4.0.2
+ '[' /var/tmp/wxPythonGTK-py2.2-buildroot '!=' / ']'
+ rm -rf /var/tmp/wxPythonGTK-py2.2-buildroot
+ exit 0
[herrold@dhcp249 dl]$ cat /etc/redhat-release
Red Hat Linux release 8.0.93 (Phoebe)
[herrold@dhcp249 dl]$

------------------------------------------------

going to install it, I get:

> > [herrold@dhcp249 dl]$ cat /etc/redhat-release
> > Red Hat Linux release 8.0.93 (Phoebe)
> > [herrold@dhcp249 dl]$
> ENS
> END
[herrold@dhcp249 dl]$ sudo rpm -Uvh
/home/herrold/redhat/RPMS/i386/wxPythonGTK-py2.2-2.4.0.2-2.i386.rpm
Password:
error: Failed dependencies:
        libwx_gtkd-2.4.so is needed by wxPythonGTK-py2.2-2.4.0.2-2
        libwx_gtkd-2.4.so(WXGTKD_2.4) is needed by wxPythonGTK-py2.2-2.4.0.2-2
        libwx_gtkd_gl-2.4.so is needed by wxPythonGTK-py2.2-2.4.0.2-2
        libwx_gtkd_gl-2.4.so(WXGTKD_2.4) is needed by
wxPythonGTK-py2.2-2.4.0.2-2

====================================

It is not finding its own provided libraries.  I will attach  this:
$ sudo rpm -Uvvvh \
/home/herrold/redhat/RPMS/i386/wxPythonGTK-py2.2-2.4.0.2-2.i386.rpm

which is longish in a moment.

and also wx-find-prov which is longish as well in a moo\ment
Comment 1 R P Herrold 2003-02-13 13:06:50 EST
Created attachment 90059 [details]
attenpted install with --vv
Comment 2 R P Herrold 2003-02-13 13:07:43 EST
Created attachment 90060 [details]
built time finds and provides stanza
Comment 3 R P Herrold 2003-02-16 18:39:14 EST
The issue persists with the latest and greatest ...


Swap:       262072      18304     243768
[herrold@dhcp249 i386]$ sudo rpm -Uvh
/home/herrold/redhat/RPMS/i386/wxPythonGTK-py2.2-2.4.0.2-2.i386.rpm
Password:
error: Failed dependencies:
        libwx_gtkd-2.4.so is needed by wxPythonGTK-py2.2-2.4.0.2-2
        libwx_gtkd-2.4.so(WXGTKD_2.4) is needed by wxPythonGTK-py2.2-2.4.0.2-2
        libwx_gtkd_gl-2.4.so is needed by wxPythonGTK-py2.2-2.4.0.2-2
        libwx_gtkd_gl-2.4.so(WXGTKD_2.4) is needed by wxPythonGTK-py2.2-2.4.0.2-2
[herrold@dhcp249 i386]$ rpm -q rpm
rpm-4.2-0.66
[herrold@dhcp249 i386]$ rpm -qi rpm
Name        : rpm                          Relocations: (not relocateable)
Version     : 4.2                               Vendor: Red Hat, Inc.
Release     : 0.66                          Build Date: Thu 06 Feb 2003 12:12:47
PM EST
Install Date: Sun 16 Feb 2003 10:20:16 AM EST      Build Host:
porky.devel.redhat.com
Group       : System Environment/Base       Source RPM: rpm-4.2-0.66.src.rpm
Size        : 4710494                          License: GPL
Signature   : DSA/SHA1, Tue 11 Feb 2003 03:04:52 PM EST, Key ID fd372689897da07a
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : The RPM package management system.
Description :
The RPM Package Manager (RPM) is a powerful command line driven
package management system capable of installing, uninstalling,
verifying, querying, and updating software packages. Each software
package consists of an archive of files along with information about
the package like its version, a description, etc.
[herrold@dhcp249 i386]$


+ /usr/lib/rpm/redhat/brp-compress
+ /usr/lib/rpm/redhat/brp-strip /usr/bin/strip
+ /usr/lib/rpm/redhat/brp-strip-static-archive /usr/bin/strip
+ /usr/lib/rpm/redhat/brp-strip-comment-note /usr/bin/strip /usr/bin/objdump
+ umask 022
+ cd /home/herrold/redhat/BUILD
+ cd wxPythonSrc-2.4.0.2
+
DOCDIR=/var/tmp/wxPythonGTK-py2.2-buildroot/usr/share/doc/wxPythonGTK-py2.2-2.4.0.2
+ export DOCDIR
+ rm -rf
/var/tmp/wxPythonGTK-py2.2-buildroot/usr/share/doc/wxPythonGTK-py2.2-2.4.0.2
+ /bin/mkdir -p
/var/tmp/wxPythonGTK-py2.2-buildroot/usr/share/doc/wxPythonGTK-py2.2-2.4.0.2
+ cp -pr docs/preamble.txt docs/licence.txt docs/readme.txt docs/changes.txt
/var/tmp/wxPythonGTK-py2.2-buildroot/usr/share/doc/wxPythonGTK-py2.2-2.4.0.2
+ cp -pr wxPython/README.txt wxPython/CHANGES.txt
/var/tmp/wxPythonGTK-py2.2-buildroot/usr/share/doc/wxPythonGTK-py2.2-2.4.0.2
+ exit 0
+ umask 022
+ cd /home/herrold/redhat/BUILD
+ cd wxPythonSrc-2.4.0.2
+ '[' /var/tmp/wxPythonGTK-py2.2-buildroot '!=' / ']'
+ rm -rf /var/tmp/wxPythonGTK-py2.2-buildroot
+ exit 0


Executing(%doc): /bin/sh -e /var/tmp/rpm-tmp.84245
Provides: calendarc.so dllwidget_c.so gizmosc.so glcanvasc.so gridc.so helpc.so
htmlc.so libwx_gtkd-2.4.so.0.0.0 libwx_gtkd-2.4.so.0.0.0(WXGTKD_2.4)
libwx_gtkd_gl-2.4.so.0.0.0 libwx_gtkd_gl-2.4.so.0.0.0(WXGTKD_2.4) oglc.so
stc_c.so wizardc.so wxPython = 2.4.0.2 wxPythonGTK = 2.4.0.2 wxc.so xrcc.so
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(VersionedDependencies) <= 3.0.3-1
Requires: /usr/bin/env libGL.so.1 libGLU.so.1 libX11.so.6 libXext.so.6
libXi.so.6 libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.1.3) libc.so.6(GLIBC_2.2) libc.so.6(GLIBC_2.3) libdl.so.2
libdl.so.2(GLIBC_2.0) libdl.so.2(GLIBC_2.1) libgcc_s.so.1 libgcc_s.so.1(GCC_3.0)
libgcc_s.so.1(GLIBC_2.0) libgdk-1.2.so.0 libglib-1.2.so.0 libgmodule-1.2.so.0
libgthread-1.2.so.0 libgtk-1.2.so.0 libm.so.6 libm.so.6(GLIBC_2.0)
libpthread.so.0 libpthread.so.0(GLIBC_2.0) libpthread.so.0(GLIBC_2.1)
libpthread.so.0(GLIBC_2.2) libpthread.so.0(GLIBC_2.3.2) libstdc++.so.5
libstdc++.so.5(CXXABI_1.2) libstdc++.so.5(GLIBCPP_3.2) libwx_gtkd-2.4.so
libwx_gtkd-2.4.so(WXGTKD_2.4) libwx_gtkd_gl-2.4.so libwx_gtkd_gl-2.4.so(WXGTKD_2.4)
Obsoletes: wxPython
Processing files: wxPythonGTK-devel-2.4.0.2-2
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires: /bin/sh wxPythonGTK = 2.4.0.2
Processing files: wxPythonGTK-py2.2-debuginfo-2.4.0.2-2
Provides: calendarc.so.debug dllwidget_c.so.debug gizmosc.so.debug
glcanvasc.so.debug gridc.so.debug helpc.so.debug htmlc.so.debug
libwx_gtkd-2.4.so.0.0.0.debug libwx_gtkd_gl-2.4.so.0.0.0.debug oglc.so.debug
stc_c.so.debug wizardc.so.debug wxc.so.debug xrcc.so.debug
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Checking for unpackaged file(s): /usr/lib/rpm/check-files
/var/tmp/wxPythonGTK-py2.2-buildroot
Wrote: /home/herrold/redhat/SRPMS/wxPythonGTK-py2.2-2.4.0.2-2.src.rpm
Wrote: /home/herrold/redhat/RPMS/i386/wxPythonGTK-py2.2-2.4.0.2-2.i386.rpm
Wrote: /home/herrold/redhat/RPMS/i386/wxPythonGTK-devel-2.4.0.2-2.i386.rpm
Wrote: /home/herrold/redhat/RPMS/i386/wxPythonGTK-py2.2-debuginfo-2.4.0.2-2.i386.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.54589


Comment 4 R P Herrold 2003-02-16 18:43:33 EST
... building rpm-4.2-0.68.src.rpm from Rawhide to test further ...
Comment 5 R P Herrold 2003-02-16 21:51:58 EST
bumped RPM to current rawhide   rpm-4.2-0.68.src.rpm
 in 84438 on build host ...
Comment 6 R P Herrold 2003-02-16 23:11:57 EST
no joy with the new rpm -- same issue:


Processing files: wxPythonGTK-py2.2-2.4.0.2-2
Executing(%doc): /bin/sh -e /var/tmp/rpm-tmp.60729
Provides: calendarc.so dllwidget_c.so gizmosc.so glcanvasc.so gridc.so helpc.so
htmlc.so libwx_gtkd-2.4.so.0.0.0 libwx_gtkd-2.4.so.0.0.0(WXGTKD_2.4)
libwx_gtkd_gl-2.4.so.0.0.0 libwx_gtkd_gl-2.4.so.0.0.0(WXGTKD_2.4) oglc.so
stc_c.so wizardc.so wxPython = 2.4.0.2 wxPythonGTK = 2.4.0.2 wxc.so xrcc.so
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(VersionedDependencies) <= 3.0.3-1
Requires: /usr/bin/env libGL.so.1 libGLU.so.1 libX11.so.6 libXext.so.6
libXi.so.6 libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.1.3) libc.so.6(GLIBC_2.2) libc.so.6(GLIBC_2.3) libdl.so.2
libdl.so.2(GLIBC_2.0) libdl.so.2(GLIBC_2.1) libgcc_s.so.1 libgcc_s.so.1(GCC_3.0)
libgcc_s.so.1(GLIBC_2.0) libgdk-1.2.so.0 libglib-1.2.so.0 libgmodule-1.2.so.0
libgthread-1.2.so.0 libgtk-1.2.so.0 libm.so.6 libm.so.6(GLIBC_2.0)
libpthread.so.0 libpthread.so.0(GLIBC_2.0) libpthread.so.0(GLIBC_2.1)
libpthread.so.0(GLIBC_2.2) libpthread.so.0(GLIBC_2.3.2) libstdc++.so.5
libstdc++.so.5(CXXABI_1.2) libstdc++.so.5(GLIBCPP_3.2) libwx_gtkd-2.4.so
libwx_gtkd-2.4.so(WXGTKD_2.4) libwx_gtkd_gl-2.4.so libwx_gtkd_gl-2.4.so(WXGTKD_2.4)
Obsoletes: wxPython
Processing files: wxPythonGTK-devel-2.4.0.2-2
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires: /bin/sh wxPythonGTK = 2.4.0.2
Processing files: wxPythonGTK-py2.2-debuginfo-2.4.0.2-2
Provides: calendarc.so.debug dllwidget_c.so.debug gizmosc.so.debug
glcanvasc.so.debug gridc.so.debug helpc.so.debug htmlc.so.debug
libwx_gtkd-2.4.so.0.0.0.debug libwx_gtkd_gl-2.4.so.0.0.0.debug oglc.so.debug
stc_c.so.debug wizardc.so.debug wxc.so.debug xrcc.so.debug
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Checking for unpackaged file(s): /usr/lib/rpm/check-files
/var/tmp/wxPythonGTK-py2.2-buildroot
Wrote: /home/herrold/redhat/SRPMS/wxPythonGTK-py2.2-2.4.0.2-2.src.rpm
Wrote: /home/herrold/redhat/RPMS/i386/wxPythonGTK-py2.2-2.4.0.2-2.i386.rpm
Wrote: /home/herrold/redhat/RPMS/i386/wxPythonGTK-devel-2.4.0.2-2.i386.rpm


[herrold@dhcp249 dl]$ sudo rpm -Uvh
/home/herrold/redhat/RPMS/i386/wxPythonGTK-py2.2-2.4.0.2-2.i386.rpm
Password:
error: Failed dependencies:
        libwx_gtkd-2.4.so is needed by wxPythonGTK-py2.2-2.4.0.2-2
        libwx_gtkd-2.4.so(WXGTKD_2.4) is needed by wxPythonGTK-py2.2-2.4.0.2-2
        libwx_gtkd_gl-2.4.so is needed by wxPythonGTK-py2.2-2.4.0.2-2
        libwx_gtkd_gl-2.4.so(WXGTKD_2.4) is needed by wxPythonGTK-py2.2-2.4.0.2-2
[herrold@dhcp249 dl]$
Comment 7 Alan Olsen 2003-07-02 21:29:38 EDT
I think I know what is happening. i have seen this in a different set of packages.

When a package is depreciated with the Obsoletes tag, some of the information
does not get removed.

Example:

Aspell and pspell.

You build 0.50 version of aspell and have it obsolete pspell in the package. 
Now upgrade aspell with -Uvh.  

Now try and build a package that depends on pspell.

Notice that it will use the version number of the old pspell library in the
requires, not the new library version.

Something is not being removed from the rpm database correctly.

This has bitten me at least once, if not more.
Comment 8 R P Herrold 2003-07-03 00:13:36 EDT
hmmm -- interesting observation, alan@immunix.com

It is not annotated here (I will dig out the details), but I think it turns out,
at least with respect to Tk/Tcl related code, these libraries are not exporting
symbols in a fashion which the RPM finds/provides code can process to produce
good results with.

But if the aspell/pspell code is truly not asymetrically clean, that is a new
and if reproduceable, troubling bug, indicating that TPM's database operations
are suffering.

Can you get a clean test case with a fresh install?  (perhaps obvuiously, a new
bug would also be in order, -- please add me to the CC of any such)
Comment 9 Alan Olsen 2003-07-03 14:13:11 EDT
Let me clarify because I may be speaking of a new bug:

You have package A that provides library libbogo.1.1.1.so.  

Package B comes along and obsoletes package A and provides library libbogo.  The
version it uses is libbogo.2.2.2.so.

You install package B.  It should remove all of the libbogo references that were
put there by package A. (In theory.)

You then build another package that references libbogo. (-lbogo)  When it gets
to the point of assigning dependancies, it will claim that the version of
libbogo needed is libbogo.1.1.1.so (from package A), not libbogo.2.2.2.so from
package B. 

The libbogo.1.1.1.so was removed as part of the upgrade process, but the
reference in the database was not.

I will put together a working reproducable test case.  BTW, this is with RPM
4.0.4.  I have not tested it with later versions.  I cannot find a bug entry for
the condition, so it may exist in later code.  (RPM 4.0.4 is what ships with
Redhat 7.3.)


.
Comment 10 R P Herrold 2005-02-23 11:41:29 EST
more than six months old - long since overtaken by events - closing; please
reopen if appropriate

Note You need to log in before you can comment on or make changes to this bug.