Bug 842318 - package /etc/xdg/autostart files as %config
package /etc/xdg/autostart files as %config
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tracker (Show other bugs)
17
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-23 09:10 EDT by Gerd v. Egidy
Modified: 2012-09-25 12:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-25 12:41:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch to the .spec (475 bytes, patch)
2012-07-23 09:10 EDT, Gerd v. Egidy
no flags Details | Diff

  None (edit)
Description Gerd v. Egidy 2012-07-23 09:10:03 EDT
Created attachment 599778 [details]
proposed patch to the .spec

Description of problem:

Currently the files in /etc/xdg/autostart owned by tracker are defined as regular files in the .spec.

Now I modify these files to provide system-wide defaults better fitting for my users.

When an updated version of tracker is released and I update the rpm, the rpm will overwrite my modifications without backup or anything.

If the files are tagged with %config instead, rpm will not overwrite them (but provide updated versions with .rpmnew suffix).

Other packages which provide autostart files (e.g. pulseaudio) also tag theirs as %config.
Comment 1 Elliott Forney 2012-08-09 16:57:52 EDT
I second this.  As an administrator of a large network, there are a number of applications started from /etc/xdg/autostart that I wish I could disable by default.
Comment 2 Rex Dieter 2012-09-18 18:55:28 EDT
Deji, any objection if I incorporate this patch?

Gerd, did you really only want 
%config
or
%config(noreplace)
?  (the latter seems to be closer to what you want)
Comment 3 Deji Akingunola 2012-09-20 11:38:28 EDT
I'm sorry for taking a long time to respond to this bug.

I have now applied the change to F17, F18 and rawhide. Thanks to gerd and Rex for the patch.
Comment 4 Fedora Update System 2012-09-20 12:08:31 EDT
tracker-0.14.2-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/tracker-0.14.2-3.fc17
Comment 5 Fedora Update System 2012-09-20 12:08:57 EDT
tracker-0.14.2-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/tracker-0.14.2-4.fc18
Comment 6 Fedora Update System 2012-09-21 19:57:17 EDT
Package tracker-0.14.2-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tracker-0.14.2-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14445/tracker-0.14.2-3.fc17
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-09-25 12:41:03 EDT
tracker-0.14.2-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.