Bug 842402 - Re-Aligning Subscription Manager Gui (removing extra layout indents)
Re-Aligning Subscription Manager Gui (removing extra layout indents)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 7.0
Assigned To: Bryan Kearney
Entitlement Bugs
:
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2012-07-23 14:52 EDT by Matt Reid
Modified: 2014-03-27 16:16 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-17 08:58:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sub-man indentation (471.55 KB, image/png)
2013-10-15 13:32 EDT, Sharath Dwaral
no flags Details
the attached subscription in My Subscritions.png (1.45 MB, image/png)
2014-01-14 22:35 EST, qianzhan
no flags Details
My Installed Products indentation.png (86.40 KB, image/png)
2014-01-16 01:30 EST, qianzhan
no flags Details
My Subscriptions indentation with expired subcription.png (114.23 KB, image/png)
2014-01-16 01:31 EST, qianzhan
no flags Details
All Available Subscriptions indentation after pressing Update button.png (120.18 KB, image/png)
2014-01-16 01:32 EST, qianzhan
no flags Details

  None (edit)
Description Matt Reid 2012-07-23 14:52:47 EDT
We currently have several layers of indentations in our Subscription Manager tabs, we have our primary table at one depth, the Details Pane Header slightly indented, and the details pane itself slightly indented again. We also slightly indent the right side of the details pane.

I think Subscription Manager would end up looking a lot cleaner if we removed all of these little indentations and flattened everything to a uniform depth, giving a strong left hand edge that is easy to scan. I don't feel like our tiny indents do a great job conveying hierarchy, and just make it harder to scan the information. The positioning of the information and titles should be sufficient to explain the hierarchy. 

I think we should consider simplifying the display of information to only use one indent, instead of having 4 different levels.

You can see an example here - https://engineering.redhat.com/trac/subscription-manager/attachment/wiki/GUIRedesign/Realigning%20Subscription%20Manager.png
Comment 2 Matt Reid 2013-07-26 14:12:57 EDT
I like the first AFTER, which just realigns things and doesn't move around the text. http://file.rdu.redhat.com/~cschevia/subman_726_1.png

Dangerous question, we have to manually tweak each tab right? At this point you've only touched the My Installed Products tab? It would be great if those changes were made to the other two as well, fixing the Subscription Details panes.

Looks really good so far, nicely done!

For context -
Original: http://file.rdu.redhat.com/~cschevia/subman_726_3.png
Edited - Uniform indent: http://file.rdu.redhat.com/~cschevia/subman_726_1.png
Edited - Adjusted spacing: http://file.rdu.redhat.com/~cschevia/subman_726_2.png
Comment 5 Sharath Dwaral 2013-10-15 13:32:35 EDT
Created attachment 812636 [details]
sub-man indentation

# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.29-1
subscription-manager: 1.10.3-1.el7
python-rhsm: 1.10.3-1.el7


It can be seen from the attachment that, all tables and text in all tabs are indented to left.

VERIFIED
Comment 6 qianzhan 2014-01-14 22:34:45 EST
I found that the attached subscriptions are not indented to left (please see attachment "the attached subscription in My Subscritions.png"), so I reopened this bug.


[root@dhcp-65-192 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 1.4.3.23-1.el6sam_splice-Headpin
subscription-manager: 1.10.10-1.el7
python-rhsm: 1.10.10-1.el7
Comment 7 qianzhan 2014-01-14 22:35:55 EST
Created attachment 850330 [details]
the attached subscription in My Subscritions.png
Comment 8 Matt Reid 2014-01-15 10:22:12 EST
Thanks for raising this, but it looks like everything is working as intended in your screenshot. If Sharath's screenshot had been after attaching a subscription, you'd see that his My Subscriptions tab would look the same as yours. The subscriptions listed in My Subscriptions are indented a bit to leave room for when we need to show an expiring warning icon.
Comment 9 qianzhan 2014-01-16 01:29:54 EST
(In reply to Matt Reid from comment #8)
> Thanks for raising this, but it looks like everything is working as intended
> in your screenshot. If Sharath's screenshot had been after attaching a
> subscription, you'd see that his My Subscriptions tab would look the same as
> yours. The subscriptions listed in My Subscriptions are indented a bit to
> leave room for when we need to show an expiring warning icon.

Hi Matt,

After making the client's system time as expired, I got three screenshots from the subscription-manager-gui's three tabs.

(1) The screenshot for My Installed Products (see attachment 'My Installed Products indentation.png'), is working.

(2) The one for My Subscriptions ( see attachment "My Subscriptions indentation with expired subcription.png "), is not working. Compared with (1), there still is a bit room before the expired warning icon.

(3) The one for All Available Subscriptions ( see attachment "All Available Subscriptions indentation after pressing Update button.png "), is not working neither. All the available subscriptions are not indented to left.

So, I believe phenomenons (2) and (3) need to be fixed.
Comment 10 qianzhan 2014-01-16 01:30:55 EST
Created attachment 850871 [details]
My Installed Products indentation.png
Comment 11 qianzhan 2014-01-16 01:31:40 EST
Created attachment 850872 [details]
My Subscriptions indentation with expired subcription.png
Comment 12 qianzhan 2014-01-16 01:32:36 EST
Created attachment 850873 [details]
All Available Subscriptions indentation after pressing Update button.png
Comment 13 Bryan Kearney 2014-01-17 08:58:07 EST
The spacing you see on the left is space for other icons (expiring) and space for the widget which shows stacking. We can not move them over. Since this was verified earlier, I am marking this as CLOSED.

Note You need to log in before you can comment on or make changes to this bug.