Bug 842406 - suspend breaks kvm processor pinning
suspend breaks kvm processor pinning
Status: CLOSED DUPLICATE of bug 714271
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-23 15:10 EDT by Robert Story
Modified: 2012-07-23 15:23 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-23 15:23:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-manager pinning on running guest before suspend (92.69 KB, image/png)
2012-07-23 15:11 EDT, Robert Story
no flags Details
virt manager guest pinning after suspend/resume (87.51 KB, image/png)
2012-07-23 15:11 EDT, Robert Story
no flags Details
/var/log/messages for suspend/resume (12.71 KB, text/plain)
2012-07-23 15:12 EDT, Robert Story
no flags Details

  None (edit)
Description Robert Story 2012-07-23 15:10:42 EDT
Description of problem:
After a fresh boot, my kvm guest with 4 cpus assigned is pinned to all 8 cpus on the host. After a suspend/resume, the same guest (all guests, in fact) will pin all virtual vpus to host cpu0.

Version-Release number of selected component (if applicable):
kernel-3.4.4-4.fc16.x86_64

How reproducible:
100%

Steps to Reproduce:
1. start multi-cpu guest on multi-cpu host
2. observer virtual cpus pinned to all host cpus
3. suspend/resume host
4. observe virtual cpus pinned to host cpu 0

Actual results:
virtual cpus pinned to cpu0

Expected results:
virtual cpus pinned to all (or configured) cpus

Additional info:
I found this fedora forum post of another user with the same issue: http://forums.fedoraforum.org/archive/index.php/t-278464.html
Comment 1 Robert Story 2012-07-23 15:11:16 EDT
Created attachment 599844 [details]
virt-manager pinning on running guest before suspend
Comment 2 Robert Story 2012-07-23 15:11:58 EDT
Created attachment 599845 [details]
virt manager guest pinning after suspend/resume
Comment 3 Robert Story 2012-07-23 15:12:44 EDT
Created attachment 599846 [details]
/var/log/messages for suspend/resume
Comment 4 Eric Blake 2012-07-23 15:23:54 EDT

*** This bug has been marked as a duplicate of bug 714271 ***

Note You need to log in before you can comment on or make changes to this bug.