Bug 842432 - Under load katello renders subscriptions on the content tab incorrectly
Under load katello renders subscriptions on the content tab incorrectly
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.0
Unspecified Unspecified
urgent Severity medium (vote)
: Unspecified
: --
Assigned To: Tom McKay
Katello QA List
: Triaged
Depends On:
Blocks: 842434
  Show dependency treegraph
 
Reported: 2012-07-23 16:49 EDT by Eric Sammons
Modified: 2013-03-27 16:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 842434 (view as bug list)
Environment:
Last Closed: 2012-08-08 12:22:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
showing the rendering of the content tab / subscriptions. (77.86 KB, image/png)
2012-07-23 16:49 EDT, Eric Sammons
no flags Details

  None (edit)
Description Eric Sammons 2012-07-23 16:49:52 EDT
Created attachment 599858 [details]
showing the rendering of the content tab / subscriptions.

Description of problem:
During testing of loading and subscribing 255 systems it was discovered that after the job's completion the subscriptions on the content tab were rendered incorrectly.

Version-Release number of selected component (if applicable):
katello-all-0.2.45-1.git.35.049d74c.fc16.noarch

How reproducible:
Additional testing to see if this is reproducible

Steps to Reproduce:
1. Provision F16
2. yum install -y katello-all
3. katello-configure --deployment=headpin
4. Load a manifest into ACME_Corporation
5. /usr/share/katello/scripts/test/populate-systems.py --url=https://fqdn/headpin -n 255
  
Actual results:
See screenshot attached

Expected results:
Correct rendering of subscriptions and consumed X of XXX values.
Comment 1 Mike McCune 2012-08-08 11:19:52 EDT
This isn't really load issue, it is just an issue that the Subscriptions page needs better organization when you have lots of systems that each have their own unique subscription.

This should be a RFE/backlog item because the system is acting as designed, although somewhat confusing.
Comment 3 Tom McKay 2012-08-08 12:22:31 EDT
This is working as designed. Some thought is warranted in how to better show related subscriptions. Task added to backlog.

Note You need to log in before you can comment on or make changes to this bug.