Bug 842436 - Packaged version of CMYKtool is unstable, frequently crashes
Packaged version of CMYKtool is unstable, frequently crashes
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: cmyktool (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Máirín Duffy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-23 16:53 EDT by Andrew Ter-Grigoryan
Modified: 2013-03-02 13:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-02 13:37:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Ter-Grigoryan 2012-07-23 16:53:40 EDT
The packaged version of CMYKtool in F17 (.1.6pre) is far too unstable, and crashes frequently. This application fulfills an important niche, but it looks like the project's dormant now. How about packaging an older, stable version instead?
Comment 1 Máirín Duffy 2012-07-24 10:17:50 EDT
Hi Andrew, I haven't had any crashes or instability with this tool - can you give me more details about what you're seeing?
Comment 2 Andrew Ter-Grigoryan 2012-07-24 13:53:51 EDT
For instance, when I try to open the Preferences, the program immediately crashes.
Comment 3 Máirín Duffy 2012-07-25 13:23:50 EDT
Hi Andrew, I definitely can't reproduce that crash. Can you maybe generate some kind of traceback for me to look at? Does ABRT give you a traceback at all? If not, here's the GDB docs:

http://www.unknownroad.com/rtfm/gdbtut/gdbuse.html#RUN

Essentially, on a terminal type 'gdb cmyktool' and at the gdb prompt type 'run' and try to reproduce a crash, then check the gdb output and copy/paste it here. Sound do-able?

I really appreciate your filing the bug, I just need some more clues as to why it might be crashing on your system because it seems pretty stable on mine.
Comment 4 Andrew Ter-Grigoryan 2012-07-26 20:09:50 EDT
The following is the output when trying to start cmyktool through GNU debugger, then opening Preferences:

$ gdb cmyktool
GNU gdb (GDB) Fedora (7.4.50.20120120-49.fc17)
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/cmyktool...(no debugging symbols found)...done.
Missing separate debuginfos, use: debuginfo-install cmyktool-0.1.6-0.1.pre1.fc17.i686
(gdb) run
Starting program: /usr/bin/cmyktool 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/libthread_db.so.1".
[New Thread 0xb7d02b40 (LWP 2291)]
[New Thread 0xb7501b40 (LWP 2292)]
[New Thread 0xb6d00b40 (LWP 2293)]

(cmyktool:2288): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(cmyktool:2288): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(cmyktool:2288): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(cmyktool:2288): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(cmyktool:2288): Gtk-CRITICAL **: gtk_text_buffer_emit_insert: assertion `g_utf8_validate (text, len, NULL)' failed
process 2288: arguments to dbus_message_iter_append_basic() were incorrect, assertion "_dbus_check_is_valid_utf8 (*string_p)" failed in file dbus-message.c line 2526.
This is normally a bug in some application using the D-Bus library.
  D-Bus not built with -rdynamic so unable to print a backtrace

Program received signal SIGABRT, Aborted.
0xb7fff424 in __kernel_vsyscall ()
(gdb) ^CQuit
(gdb) quit
Comment 5 Andrew Ter-Grigoryan 2013-03-02 13:37:43 EST
CMYKtool in F17 is no longer unstable.

Closed.

Note You need to log in before you can comment on or make changes to this bug.