Bug 842444 - Need staging mei module to resume from suspend sucessfully
Need staging mei module to resume from suspend sucessfully
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-23 17:23 EDT by markzzzsmith
Modified: 2012-08-05 10:20 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-05 10:20:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description markzzzsmith 2012-07-23 17:23:00 EDT
Description of problem:

For the last few 3.4 kernel versions, I've had trouble with resuming from suspend. Resuming seemed to work completely successfully, however approximately 30 seconds after resuming, my system would cold reboot. This did not happen if I hibinated the machine instead.

I'm aware my system has Intel Active Management Technology (AMT), that it has a hardware watchdog, and that the staging mei module is a driver for it. I guessed that the watchdog may have been firing, as there was no evidence of a hardware fault. I installed the staging kernel modules so that the mei module was available. After installing the mei module, my system now successfully resumes from suspend.

It would seem that in recent kernels, resuming without the mei module installed is not putting the AMT hardware back into the same state that the system boot does, and that causes the watchdog timer to go off.

Version-Release number of selected component (if applicable):

Various 3.4 kernels, including current 3.4.6-2.

How reproducible:

Every time I suspend the machine.

Steps to Reproduce:
1. Suspend the machine
2. Resume
3. Wait approximately 30 seconds, and then observe the machine cold reboot
  
Actual results:

System apparently reboots for no reason.

Expected results:

System does not reboot.

Additional info:

Work around is to install the staging modules (via the meta package, so that kernel upgrades drag in the corresponding kernel staging module). The mei module is loaded automatically at boot.
Comment 1 Dave Jones 2012-07-23 17:53:44 EDT
looks like this just moved out of staging/, so this doesn't seem unreasonable.
Comment 2 markzzzsmith 2012-07-24 05:30:31 EDT
That's good news. I figured I'd report it more because I didn't think I should need to have staging modules available to have reliable suspend/resume. If the mei module is going to be a non-staging module in 3.5, and that isn't too far away as a fedora kernel, then this bug could probably be closed as there is a work around.
Comment 3 Josh Boyer 2012-07-24 07:48:13 EDT
F17 is probably going to be rebased to 3.5 later this week.  We'll leave this bug open though to remember why we enabled the mei module.
Comment 4 markzzzsmith 2012-07-24 08:52:46 EDT
Ok, thanks.
Comment 5 Josh Boyer 2012-07-26 09:19:55 EDT
MEI has been enabled in rawhide.  We'll enable it in F17 when the 3.5 rebase goes in, as previously mentioned.
Comment 6 Josh Boyer 2012-07-30 17:11:44 EDT
https://admin.fedoraproject.org/updates/kernel-3.5.0-2.fc17

should have the MEI module enabled.
Comment 7 markzzzsmith 2012-08-05 00:25:42 EDT
Upgrade to 3.5.0-2.fc17.x86_64 fixed this, so this bug can be closed. Thanks very much.

Note You need to log in before you can comment on or make changes to this bug.