Bug 842511 - SELinux is preventing /usr/bin/bash from 'read' accesses on the file /etc/passwd.
SELinux is preventing /usr/bin/bash from 'read' accesses on the file /etc/pas...
Status: CLOSED DUPLICATE of bug 842507
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-07-24 00:53 EDT by Gideon Mayhak
Modified: 2012-07-24 04:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-07-24 04:25:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Gideon Mayhak 2012-07-24 00:53:33 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.6-2.fc17.x86_64
time:           Mon 23 Jul 2012 11:53:22 PM CDT

:SELinux is preventing /usr/bin/bash from 'read' accesses on the file /etc/passwd.
:*****  Plugin catchall (100. confidence) suggests  ***************************
:If you believe that bash should be allowed read access on the passwd file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:allow this access for now by executing:
:# grep http_loadtime /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:Additional Information:
:Source Context                system_u:system_r:services_munin_plugin_t:s0
:Target Context                system_u:object_r:passwd_file_t:s0
:Target Objects                /etc/passwd [ file ]
:Source                        http_loadtime
:Source Path                   /usr/bin/bash
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           bash-4.2.36-1.fc17.x86_64
:Target RPM Packages           setup-2.8.48-1.fc17.noarch
:Policy RPM                    selinux-policy-3.10.0-140.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.4.6-2.fc17.x86_64 #1 SMP Thu Jul 19
:                              22:54:16 UTC 2012 x86_64 x86_64
:Alert Count                   36
:First Seen                    Mon 23 Jul 2012 11:48:11 PM CDT
:Last Seen                     Mon 23 Jul 2012 11:50:10 PM CDT
:Local ID                      d2600be9-2287-4758-8d3e-64043f50a442
:Raw Audit Messages
:type=AVC msg=audit(1343105410.525:204): avc:  denied  { read } for  pid=3315 comm="ntp_offset" name="passwd" dev="dm-0" ino=1050262 scontext=system_u:system_r:services_munin_plugin_t:s0 tcontext=system_u:object_r:passwd_file_t:s0 tclass=file
:type=SYSCALL msg=audit(1343105410.525:204): arch=x86_64 syscall=open success=no exit=EACCES a0=7f7bdc9c86ca a1=80000 a2=1b6 a3=238 items=0 ppid=2800 pid=3315 auid=4294967295 uid=99 gid=482 euid=99 suid=99 fsuid=99 egid=482 sgid=482 fsgid=482 tty=(none) ses=4294967295 comm=ntp_offset exe=/usr/bin/bash subj=system_u:system_r:services_munin_plugin_t:s0 key=(null)
:Hash: http_loadtime,services_munin_plugin_t,passwd_file_t,file,read
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
Comment 1 Miroslav Grepl 2012-07-24 04:25:30 EDT

*** This bug has been marked as a duplicate of bug 842507 ***

Note You need to log in before you can comment on or make changes to this bug.