Bug 842519 - Failed to install some extensions/modules to php-5.3 app using deplist.txt
Failed to install some extensions/modules to php-5.3 app using deplist.txt
Status: CLOSED UPSTREAM
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan Mace
libra bugs
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-24 01:40 EDT by jizhao
Modified: 2015-05-14 18:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-10 20:21:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error log of git push (12.17 KB, text/plain)
2012-07-24 02:29 EDT, jizhao
no flags Details

  None (edit)
Description jizhao 2012-07-24 01:40:58 EDT
Description of problem:
Create a php-5.3 app and add "pecl/mongo" to its deplist.txt. Git push. The installation of mongo module always fail because it tries to copy mongo.so to /usr/lib64/php/modules/. Some other modules like "pear/Auth" also have the same problem. Maybe we should change the php configuration to make pecl install the module to some other place.

Version-Release number of selected component (if applicable):
devenv_1907

How reproducible:
Always

Steps to Reproduce:
1.Create a php-5.3 app
2.Add one line to <git_repo>/deplist.txt
==> <git_repo>/deplist.txt <==
pecl/mongo

3.Git push all the changes
  
Actual results:
<---------------output------------------->
remote: Build process completed successfully
remote: Installing '/usr/lib64/php/modules/mongo.so'
remote: ERROR: failed to write /usr/lib64/php/modules/mongo.so (copy(/usr/lib64/php/modules/mongo.so): failed to open stream: Permission denied)
remote: Running .openshift/action_hooks/build
remote: Running .openshift/action_hooks/deploy
remote: Starting application...
remote: Done
<---------------------------------------->

Expected results:
mongo module should be installed successfully.

Additional info:
Comment 1 jizhao 2012-07-24 02:29:05 EDT
Created attachment 599922 [details]
error log of git push

There're some other extensions/modules which can't be installed successfully. Please decide whether they're bugs or not.
Comment 2 Dan Mace 2012-08-23 16:00:57 EDT
There seems to be an upstream bug in the Pear install function which prevents us from properly configuring the output location of compiled Pecl modules. Compilation will succeed, but the resulting module will always be copied to /usr and will fail while doing so. There needs to be a decision made to either wait for an upstream fix, or to try and work around it ourselves.
Comment 3 Jhon Honce 2012-10-10 20:21:48 EDT
US2119 Custom PHP extensions

See https://rally1.rallydev.com/#/4670516379d/detail/userstory/5850814544

Note You need to log in before you can comment on or make changes to this bug.