This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 842551 - libguestfs: error: part_list: could not parse row from output of parted print command: /dev/vdb:654188544B:virtblk:512:512:unknown:Virtio Block Device:;
libguestfs: error: part_list: could not parse row from output of parted print...
Status: CLOSED DUPLICATE of bug 745606
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-24 03:37 EDT by Richard W.M. Jones
Modified: 2012-07-24 03:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-24 03:49:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2012-07-24 03:37:28 EDT
Description of problem:

For some reason this only happens with virt-alignment-scan,
not with virt-df, even though both tools do roughly the same
operations.

$ sudo virt-df -d Win2003
Filesystem                           1K-blocks       Used  Available  Use%
Win2003:/dev/sdb                        638856     638856          0  100%
Win2003:/dev/sda1                      6281380    3405532    2875848   55%

$ sudo virt-alignment-scan -d Win2003
/dev/sda1        32256          512    bad (alignment < 4K)
libguestfs: error: part_list: could not parse row from output of parted print command: /dev/vdb:654188544B:virtblk:512:512:unknown:Virtio Block Device:;

$ sudo virt-alignment-scan -d Win2003 -x
libguestfs: trace: add_domain "Win2003" "readonly:true" "allowuuid:true" "readonlydisk:read"
libguestfs: trace: add_domain = 2
libguestfs: trace: launch
libguestfs: trace: launch = 0
libguestfs: trace: list_devices
libguestfs: trace: list_devices = ["/dev/vda", "/dev/vdb"]
libguestfs: trace: part_list "/dev/vda"
libguestfs: trace: part_list = <struct guestfs_partition_list *>
/dev/sda1        32256          512    bad (alignment < 4K)
libguestfs: trace: part_list "/dev/vdb"
libguestfs: trace: part_list = NULL (error)
libguestfs: error: part_list: could not parse row from output of parted print command: /dev/vdb:654188544B:virtblk:512:512:unknown:Virtio Block Device:;
libguestfs: trace: close
libguestfs: trace: shutdown
libguestfs: trace: internal_autosync
libguestfs: trace: internal_autosync = 0
libguestfs: trace: shutdown = 0

Version-Release number of selected component (if applicable):

libguestfs 1.18.5

How reproducible:

100% on a single Windows 2003 guest with two disks.
Comment 1 Richard W.M. Jones 2012-07-24 03:46:26 EDT
Same error in libguestfs 1.19.24.
Comment 2 Richard W.M. Jones 2012-07-24 03:49:55 EDT
OK, so this is parted stupidity, and a dupe of a
bug we've already found and fixed in parted (but only
in Rawhide).

The output of the command is:

# parted -m -- /dev/vdb unit b print
Error: /dev/vdb: unrecognised disk label                                  
BYT;
/dev/vdb:654188544B:virtblk:512:512:unknown:Virtio Block Device:;

NB The error message is set to stdout.

parted-3.0-10.fc17.x86_64

*** This bug has been marked as a duplicate of bug 745606 ***

Note You need to log in before you can comment on or make changes to this bug.