Bug 842552 - [abrt] oox::drawingml::applyStyleList
[abrt] oox::drawingml::applyStyleList
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
abrt_hash:40ffb3dec9db1465539f898fc46...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-24 03:37 EDT by Sebastian Pölsterl
Modified: 2012-08-18 20:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-18 20:27:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (16.95 KB, text/plain)
2012-07-24 03:38 EDT, Sebastian Pölsterl
no flags Details
File: maps (76.36 KB, text/plain)
2012-07-24 03:38 EDT, Sebastian Pölsterl
no flags Details
File: backtrace (479.23 KB, text/plain)
2012-07-24 03:38 EDT, Sebastian Pölsterl
no flags Details
File that caused libreoffice to crash when opened (23.14 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2012-07-24 04:55 EDT, Sebastian Pölsterl
no flags Details

  None (edit)
Description Sebastian Pölsterl 2012-07-24 03:37:59 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --impress file:///home/sebp/blackthorn/the_results/new_stent_labels/template.pptx --splash-pipe=6
comment:        Trying to open a pptx file, the splash screen pops up for a fraction of a second and libreoffice crashes right at the start.
crash_function: oox::drawingml::applyStyleList
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.4.6-2.fc17.x86_64
pid:            1705
pwd:            /home/sebp
time:           Di 24 Jul 2012 09:18:18 CEST
uid:            1000
username:       sebp

backtrace:      Text file, 490729 bytes
dso_list:       Text file, 17358 bytes
maps:           Text file, 78188 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/sebp/2

core_backtrace:
:ef430603be73057aa3f9e5cd0f7483e5de563a2d 0x459a04 - libooxlo.so -
:ef430603be73057aa3f9e5cd0f7483e5de563a2d 0x45a431 - libooxlo.so -
:ef430603be73057aa3f9e5cd0f7483e5de563a2d 0x451fd8 - libooxlo.so -
:ef430603be73057aa3f9e5cd0f7483e5de563a2d 0x43ecf5 - libooxlo.so -
:ef430603be73057aa3f9e5cd0f7483e5de563a2d 0x445dc1 - libooxlo.so -
:ef430603be73057aa3f9e5cd0f7483e5de563a2d 0x42ee4f - libooxlo.so -
:ef430603be73057aa3f9e5cd0f7483e5de563a2d 0x4e827a - libooxlo.so -
:ef430603be73057aa3f9e5cd0f7483e5de563a2d 0x4f6c8a - libooxlo.so -
:ef430603be73057aa3f9e5cd0f7483e5de563a2d 0x4efd9f - libooxlo.so -
:24153b819ee67a48d7eb53fe7acf172799cf2364 0x914e - fastsax.uno.so -
:ef430603be73057aa3f9e5cd0f7483e5de563a2d 0x105c1c - libooxlo.so -
:ef430603be73057aa3f9e5cd0f7483e5de563a2d 0x105d1c - libooxlo.so -
:ef430603be73057aa3f9e5cd0f7483e5de563a2d 0x115de2 oox::core::XmlFilterBase::importFragment(rtl::Reference<oox::core::FragmentHandler> libooxlo.so -
:ef430603be73057aa3f9e5cd0f7483e5de563a2d 0x4e3d70 - libooxlo.so -
:ef430603be73057aa3f9e5cd0f7483e5de563a2d 0x109a9b oox::core::FilterBase::filter(com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> libooxlo.so -
:ef430603be73057aa3f9e5cd0f7483e5de563a2d 0x4e3e16 - libooxlo.so -
:a39579db094598a314b6dfba376b9678e328f1d8 0x2a1caf SfxObjectShell::ImportFrom(SfxMedium&, libsfxlo.so -
:782c4764d69fa84ad0da1cc29cc0ef38122556ba 0x2b1931 sd::DrawDocShell::ImportFrom(SfxMedium&, libsdlo.so -
:a39579db094598a314b6dfba376b9678e328f1d8 0x2a6708 SfxObjectShell::DoLoad(SfxMedium*) libsfxlo.so -
:a39579db094598a314b6dfba376b9678e328f1d8 0x2e06d9 SfxBaseModel::load(com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> libsfxlo.so -
:a39579db094598a314b6dfba376b9678e328f1d8 0x3143b0 - libsfxlo.so -
:abb155f4034961a945eddba15f6f93e8b2671bd1 0x10c323 - libfwklo.so -
:abb155f4034961a945eddba15f6f93e8b2671bd1 0x10d688 - libfwklo.so -
:abb155f4034961a945eddba15f6f93e8b2671bd1 0xa5c6e - libfwklo.so -
:abb155f4034961a945eddba15f6f93e8b2671bd1 0xa6198 - libfwklo.so -
:1622c13264c9005f9ce32fa6aa15ae6d25a828f5 0xd5ea4 comphelper::SynchronousDispatch::dispatch(com::sun::star::uno::Reference<com::sun::star::uno::XInterface> libcomphelpgcc3.so -
:e306f7cf861ffe3fe272fd7721cd5b892b786024 0x334e7 - libsofficeapp.so -
:e306f7cf861ffe3fe272fd7721cd5b892b786024 0x40fe1 - libsofficeapp.so -
:e306f7cf861ffe3fe272fd7721cd5b892b786024 0x1fecf - libsofficeapp.so -
:e306f7cf861ffe3fe272fd7721cd5b892b786024 0x210fc - libsofficeapp.so -
:2570df319b7fbfa8ce2d67c98cb838c5f2be4584 0x353082 - libvcllo.so -
:2570df319b7fbfa8ce2d67c98cb838c5f2be4584 0x35c751 SalGenericDisplay::DispatchInternalEvent() libvcllo.so -
:785a3d3c0ad1447d7d98bd789193dd65b80d72ee 0x30fdf - libvclplug_gtklo.so -
:785a3d3c0ad1447d7d98bd789193dd65b80d72ee 0x31059 - libvclplug_gtklo.so -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x47695 g_main_context_dispatch libglib-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x479c8 - libglib-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x47a84 g_main_context_iteration libglib-2.0.so.0 -
:785a3d3c0ad1447d7d98bd789193dd65b80d72ee 0x30d81 - libvclplug_gtklo.so -
:785a3d3c0ad1447d7d98bd789193dd65b80d72ee 0x31add - libvclplug_gtklo.so -
:2570df319b7fbfa8ce2d67c98cb838c5f2be4584 0xfbcd4 Application::Yield(bool) libvcllo.so -
:2570df319b7fbfa8ce2d67c98cb838c5f2be4584 0xfbd77 Application::Execute() libvcllo.so -
:e306f7cf861ffe3fe272fd7721cd5b892b786024 0x1dd59 - libsofficeapp.so -
:2570df319b7fbfa8ce2d67c98cb838c5f2be4584 0x102711 - libvcllo.so -
:2570df319b7fbfa8ce2d67c98cb838c5f2be4584 0x1027b5 SVMain() libvcllo.so -
:e306f7cf861ffe3fe272fd7721cd5b892b786024 0x41d26 soffice_main libsofficeapp.so -
:0ef7a32417e24ed789ff99a91ba555099483812c 0x6bb - [exe] -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=schleppi
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GIO_LAUNCHED_DESKTOP_FILE_PID=1691
:GPG_AGENT_INFO=/run/user/sebp/keyring-OVPui4/gpg:0:1
:SHELL=/bin/bash
:TERM=dumb
:DESKTOP_STARTUP_ID=nautilus-1653-schleppi-libreoffice-0_TIME191153
:HISTSIZE=1000
:GJS_DEBUG_OUTPUT=stderr
:OLDPWD=/usr/lib64/libreoffice/program
:GNOME_KEYRING_CONTROL=/run/user/sebp/keyring-OVPui4
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:USER=sebp
:SSH_AUTH_SOCK=/run/user/sebp/keyring-OVPui4/ssh
:USERNAME=sebp
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/921,unix/unix:/tmp/.ICE-unix/921
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/libreoffice-impress.desktop
:MAIL=/var/spool/mail/sebp
:PATH=/home/sebp/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/sebp/.local/bin:/home/sebp/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/sebp
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=917
:LANG=de_DE.utf8
:GDM_LANG=de_DE.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/sebp
:SHLVL=1
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=sebp
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-OQvFC1zvxc,guid=644c021cdd765686ffaf5d8400000027
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/sebp
:DISPLAY=:0.0
:XAUTHORITY=/var/run/gdm/auth-for-sebp-Ndxbdx/database
:LD_LIBRARY_PATH=/usr/java/jdk1.7.0_03/jre/lib/amd64/client:/usr/java/jdk1.7.0_03/jre/lib/amd64/server:/usr/java/jdk1.7.0_03/jre/lib/amd64/native_threads:/usr/java/jdk1.7.0_03/jre/lib/amd64

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 30929                processes 
:Max open files            4096                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       30929                30929                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/sebp/.xsession-errors
:pos:	19294
:flags:	0102002
:2:/home/sebp/.xsession-errors
:pos:	19294
:flags:	0102002
:3:socket:[44473]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:pipe:[46100]
:pos:	0
:flags:	00
:6:pipe:[46100]
:pos:	0
:flags:	01
:7:socket:[44475]
:pos:	0
:flags:	02000002

var_log_messages:
:Jul 24 09:18:18 schleppi kernel: [  195.101705] soffice.bin[1705]: segfault at 78 ip 00007f02a782da04 sp 00007fff0018c6e0 error 4 in libooxlo.so[7f02a73d4000+6ee000]
:Jul 24 09:18:19 schleppi abrt[1716]: Saved core dump of pid 1705 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-07-24-09:18:18-1705 (98418688 bytes)
:Jul 24 09:18:25 schleppi kernel: [  202.873178] soffice.bin[1748]: segfault at 78 ip 00007f767f394a04 sp 00007fff90403bd0 error 4 in libooxlo.so[7f767ef3b000+6ee000]
:Jul 24 09:18:25 schleppi abrt[1759]: Not dumping repeating crash in '/usr/lib64/libreoffice/program/soffice.bin'
Comment 1 Sebastian Pölsterl 2012-07-24 03:38:06 EDT
Created attachment 599931 [details]
File: dso_list
Comment 2 Sebastian Pölsterl 2012-07-24 03:38:08 EDT
Created attachment 599932 [details]
File: maps
Comment 3 Sebastian Pölsterl 2012-07-24 03:38:11 EDT
Created attachment 599933 [details]
File: backtrace
Comment 4 David Tardon 2012-07-24 04:41:21 EDT
Could you attach the file here?
Comment 5 Sebastian Pölsterl 2012-07-24 04:46:40 EDT
Unfortunately not because it contains confidential information, I will try to reproduce it with a different file.
Comment 6 Sebastian Pölsterl 2012-07-24 04:55:13 EDT
Created attachment 599951 [details]
File that caused libreoffice to crash when opened

Okay, this a different file which I cannot open. However, abrt didn't pop up this time, so I'm not sure if it's exactly the same issue as with the other file.
Comment 7 Sebastian Pölsterl 2012-07-24 07:32:02 EDT
Tried opening a pptx file in libreoffice

backtrace_rating: 4
Package: libreoffice-core-3.5.5.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 8 David Tardon 2012-07-26 08:16:33 EDT
As I understand it, the imported TableCell should always contain default text content.
Comment 9 David Tardon 2012-07-26 08:57:31 EDT
fix will be in libreoffice-3.5.5.3-5.fc17
Comment 10 Fedora Update System 2012-08-01 15:42:14 EDT
libreoffice-3.5.5.3-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libreoffice-3.5.5.3-5.fc17
Comment 11 Fedora Update System 2012-08-02 07:23:36 EDT
Package libreoffice-3.5.5.3-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.5.5.3-5.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11418/libreoffice-3.5.5.3-5.fc17
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2012-08-09 02:56:30 EDT
libreoffice-3.5.6.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libreoffice-3.5.6.2-1.fc17
Comment 13 Fedora Update System 2012-08-18 20:27:12 EDT
libreoffice-3.5.6.2-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.