Bug 842553 - Provider page in webui throws "Missing partial charts/time_chart with {:formats=>[:html], :handlers=>[:mustache, :rjs, :rhtml, :erb, :rxml, :haml, :builder], :locale=>[:en, :en]} in view paths "/usr/share/aeolus-conductor/app/views"
Provider page in webui throws "Missing partial charts/time_chart with {:forma...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Jan Provaznik
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-24 03:41 EDT by Aziza Karol
Modified: 2012-12-04 10:15 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A missing reference to the charts views caused the Providers page to display the following error: 'Missing partial charts/time_chart with {:formats=>[:html], :handlers=>[:mustache, :rjs, :rhtml, :erb, :rxml, :haml, :builder], :locale=>[:en, :en]} in view paths "/usr/share/aeolus-conductor/app/views"' This fix adds the reference to the charts view. The Providers page now displays a charted view without error.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:15:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
err (160.82 KB, image/png)
2012-07-24 03:47 EDT, Aziza Karol
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:1516 normal SHIPPED_LIVE CloudForms Cloud Engine 1.1 update 2012-12-04 14:51:45 EST

  None (edit)
Description Aziza Karol 2012-07-24 03:41:37 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Install aeolus.
2.login as admin and navigate to Administer->Cloud providers.

  
Actual results:
Error "Missing partial charts/time_chart with {:formats=>[:html], :handlers=>[:mustache, :rjs, :rhtml, :erb, :rxml, :haml, :builder], :locale=>[:en, :en]} in view paths "/usr/share/aeolus-conductor/app/views" is displayed.
see attached screenshot.

Expected results:
Should be able to add provider accounts.

Additional info:
rpm -qa | grep aeolus
aeolus-conductor-doc-0.11.0-0.20120724030017gite759ab7.fc16.noarch
rubygem-aeolus-image-0.6.0-0.20120723230037git05a815a.fc16.noarch
aeolus-conductor-daemons-0.11.0-0.20120724030017gite759ab7.fc16.noarch
rubygem-aeolus-cli-0.6.0-0.20120723230034git2a28761.fc16.noarch
aeolus-configure-2.7.0-0.20120723230032gitcc8302d.fc16.noarch
aeolus-all-0.11.0-0.20120724030017gite759ab7.fc16.noarch
aeolus-conductor-0.11.0-0.20120724030017gite759ab7.fc16.noarch
Comment 1 Aziza Karol 2012-07-24 03:47:05 EDT
Created attachment 599934 [details]
err
Comment 2 Jan Provaznik 2012-07-24 05:41:57 EDT
a patch sent: https://fedorahosted.org/pipermail/aeolus-devel/2012-July/011553.html
Comment 3 Jan Provaznik 2012-07-24 07:53:18 EDT
pushed to master, commit: cdc50c92a71e9d20b871f987cd92d23e7d4fd503
Comment 6 Aziza Karol 2012-09-17 02:30:22 EDT
This issue is not reproducible.Able to add provider account.

verified:
rpm -qa | grep aeolus
aeolus-conductor-0.13.7-1.el6cf.noarch
aeolus-all-0.13.7-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-doc-0.13.7-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.13.7-1.el6cf.noarch
Comment 8 errata-xmlrpc 2012-12-04 10:15:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.