Bug 842591 - felix-framework - compile with -target 1.5 or greater
felix-framework - compile with -target 1.5 or greater
Product: Fedora
Classification: Fedora
Component: felix-framework (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 842394
  Show dependency treegraph
Reported: 2012-07-24 05:23 EDT by Mikolaj Izdebski
Modified: 2012-10-21 09:46 EDT (History)
1 user (show)

See Also:
Fixed In Version: 4.0.2-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-10-21 09:46:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2012-07-24 05:23:46 EDT
Package felix-framework appears to be using Java generics,
but generates class files in format older than 49.0,
which corresponds to J2SE 5.0, in which generics were introduced.

Please update this package to generate classes in format 49.0 or
above. This corresponds to -target 1.5 option of javac (or ecj).

For more information, see bug #842394
Comment 1 Mikolaj Izdebski 2012-08-27 07:11:11 EDT
Fixed in version 4.0.2-4.
Comment 2 Mikolaj Izdebski 2012-10-10 09:15:45 EDT
This needs to be fixed in Fedora 18 too.
Causes xbean FTBFS on F18.
Comment 3 Fedora Update System 2012-10-10 09:33:42 EDT
felix-framework-4.0.2-4.fc18 has been submitted as an update for Fedora 18.
Comment 4 Fedora Update System 2012-10-10 14:06:31 EDT
Package felix-framework-4.0.2-4.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing felix-framework-4.0.2-4.fc18'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).
Comment 5 Mat Booth 2012-10-21 09:46:20 EDT
Looks like this has been pushed to stable, dunno why bodhi hasn't closed this ticket. Closing.

Note You need to log in before you can comment on or make changes to this bug.