Bug 842603 - jackson - compile with -target 1.5 or greater
jackson - compile with -target 1.5 or greater
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jackson (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Juan Hernández
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 842394
  Show dependency treegraph
 
Reported: 2012-07-24 05:24 EDT by Mikolaj Izdebski
Modified: 2013-01-07 06:39 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.9.4-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 06:39:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2012-07-24 05:24:53 EDT
Package jackson appears to be using Java generics,
but generates class files in format older than 49.0,
which corresponds to J2SE 5.0, in which generics were introduced.

Please update this package to generate classes in format 49.0 or
above. This corresponds to -target 1.5 option of javac (or ecj).

For more information, see bug #842394
Comment 1 Juan Hernández 2012-07-24 05:53:25 EDT
Actually the Jackson package generates format 49.0. The problem is that the build process bundles the classes from /usr/share/java/objectweb-asm/asm.jar, which are part of package objectweb-asm, and that package generates format 46.0.

I will remove this bundling from the jackson package.
Comment 2 Juan Hernández 2012-07-24 06:34:39 EDT
The fix for the bundling issue is fixed and the modified package built:

http://koji.fedoraproject.org/koji/taskinfo?taskID=4325235

Should we push this to Fedora 17 as well? In my opinion it is not worth.
Comment 3 Mikolaj Izdebski 2012-07-24 07:04:51 EDT
> Should we push this to Fedora 17 as well? In my opinion it is not worth.

There's no need for that.
Comment 4 Mikolaj Izdebski 2013-01-07 06:39:11 EST
Fixed in jackson-1.9.4-5

Note You need to log in before you can comment on or make changes to this bug.