Bug 842615 - ooo2gd - compile with -target 1.5 or greater
ooo2gd - compile with -target 1.5 or greater
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ooo2gd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 842394
  Show dependency treegraph
 
Reported: 2012-07-24 05:26 EDT by Mikolaj Izdebski
Modified: 2012-07-25 04:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-25 04:10:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2012-07-24 05:26:18 EDT
Package ooo2gd appears to be using Java generics,
but generates class files in format older than 49.0,
which corresponds to J2SE 5.0, in which generics were introduced.

Please update this package to generate classes in format 49.0 or
above. This corresponds to -target 1.5 option of javac (or ecj).

For more information, see bug #842394
Comment 1 David Tardon 2012-07-25 01:27:27 EDT
These are classes generated by libreoffice's javamaker. Since javamaker has been changed to generate version 1.49 classes in libreoffice 3.6, simple rebuild should be enough...
Comment 2 David Tardon 2012-07-25 04:10:50 EDT
fixed FTBFS and rebuilt

Note You need to log in before you can comment on or make changes to this bug.