Bug 842627 - xstream - compile with -target 1.5 or greater
xstream - compile with -target 1.5 or greater
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xstream (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Spaulding
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 842394
  Show dependency treegraph
 
Reported: 2012-07-24 05:27 EDT by Mikolaj Izdebski
Modified: 2012-10-14 06:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-14 06:06:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2012-07-24 05:27:42 EDT
Package xstream appears to be using Java generics,
but generates class files in format older than 49.0,
which corresponds to J2SE 5.0, in which generics were introduced.

Please update this package to generate classes in format 49.0 or
above. This corresponds to -target 1.5 option of javac (or ecj).

For more information, see bug #842394
Comment 1 Fedora Admin XMLRPC Client 2012-10-04 08:54:16 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Matt Spaulding 2012-10-13 23:00:17 EDT
The build does use -target 1.5 for the portions of the library that require it, and it uses -target 1.3 for the portions that do not. It looks to me like this should be okay.
Comment 3 Mikolaj Izdebski 2012-10-14 06:06:53 EDT
This bug was reported in automated way, with quite high ratio of false positives. I'm closing it now since xstream seems to be unaffected. Thank you for investingaing it.

Note You need to log in before you can comment on or make changes to this bug.