Bug 842652 - Renaming of directories fails on stripe volume
Renaming of directories fails on stripe volume
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.0
x86_64 Linux
high Severity urgent
: ---
: ---
Assigned To: Brian Foster
senaik
:
Depends On:
Blocks: 801887 842953
  Show dependency treegraph
 
Reported: 2012-07-24 07:25 EDT by shylesh
Modified: 2015-09-03 10:07 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0qa4-1.el6rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 842953 (view as bug list)
Environment:
Last Closed: 2013-09-23 18:32:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shylesh 2012-07-24 07:25:46 EDT
Description of problem:

Creating a directory and trying to rename it fails on stripe volume

Version-Release number of selected component (if applicable):
RHS 2.0.z

How reproducible:
Always

Steps to Reproduce:
1. Create a stripe volume
2. mount the volume and create a directory say dir1
3. renamve the directory : mv dir1 dir2
  
Actual results:
rename operation fails

[root@nec-em13 mnt]# mv dir1 dir2
mv: cannot move `dir1' to a subdirectory of itself, `dir2'




Expected results:


Additional info:
-07-24 06:32:52.121132] I [glusterfsd-mgmt.c:1565:mgmt_getspec_cbk] 0-glusterfs: No change in volfile, continuing
[2012-07-24 06:32:52.124715] I [client-handshake.c:1636:select_server_supported_programs] 0-volset-client-0: Using Program GlusterFS 3.3.0, Num (1298437), Version (330)
[2012-07-24 06:32:52.125201] I [client-handshake.c:1433:client_setvolume_cbk] 0-volset-client-0: Connected to 10.16.157.63:24011, attached to remote volume '/home/bricks/volset0'.
[2012-07-24 06:32:52.125231] I [client-handshake.c:1445:client_setvolume_cbk] 0-volset-client-0: Server and Client lk-version numbers are not same, reopening the fds
[2012-07-24 06:32:52.125537] I [client-handshake.c:453:client_set_lk_version_cbk] 0-volset-client-0: Server lk version = 1
[2012-07-24 06:34:02.342657] I [glusterfsd-mgmt.c:64:mgmt_cbk_spec] 0-mgmt: Volume file changed
[2012-07-24 06:34:02.346265] I [glusterfsd-mgmt.c:1565:mgmt_getspec_cbk] 0-glusterfs: No change in volfile, continuing
[2012-07-24 07:16:21.271285] W [fuse-bridge.c:1516:fuse_rename_cbk] 0-glusterfs-fuse: 71999: /dir1 -> /dir2 => -1 (Invalid argument)
Comment 1 Brian Foster 2012-07-24 09:11:28 EDT
http://review.gluster.com/3720
Comment 2 Vijay Bellur 2012-07-25 17:55:14 EDT
CHANGE: http://review.gluster.com/3720 (cluster/stripe: don't fail if no fctx on a non-regular file) merged in master by Anand Avati (avati@redhat.com)
Comment 4 senaik 2012-12-21 02:40:54 EST
Verified in gluster version glusterfs 3.4.0qa5

Verification Steps : 
______________________

- Created a Stripe Volume 
- Created a directory from mount point and renamed the directory 
  [root@unused stripe_vol]# mkdir dir1
  [root@unused stripe_vol]# ls
  dir1

  [root@unused stripe_vol]# mv dir1 dir2
  [root@unused stripe_vol]# ls
  dir2

Tried the above operation with coalesce 'on' and it succeeded . 

Tried the similar operations on a Stripe-Replicate Volume and it succeeded .
Comment 5 Scott Haines 2013-09-23 18:32:55 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.