Bug 842656 - [engine-core] storage domain: unable to create v3 storage domain when DC = None (able to choose v1 or v2)
[engine-core] storage domain: unable to create v3 storage domain when DC = No...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: 3.1.0
Assigned To: Daniel Erez
Dafna Ron
storage
:
Depends On: 843502
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-24 07:44 EDT by Haim
Modified: 2016-02-10 12:08 EST (History)
11 users (show)

See Also:
Fixed In Version: SI13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Haim 2012-07-24 07:44:15 EDT
Description of problem:

new storage domain dialogue, set data-center to none, storage format available for admin to choose is either v1 or v2, which is wrong, it should be:

- either allow all storage types for data-domain (v1, v2 or v3).
- either allow only v2 or v3 (since we are supporting only 3.0 and 3.1)
- either allow all the above according to storage type, meaning: 
if NFS based allow either v1 or v3, if data then allow wither v2 or v3 ..
Comment 1 Daniel Erez 2012-07-25 14:08:52 EDT
http://gerrit.ovirt.org/#/c/6629/1
Comment 4 Daniel Erez 2012-07-31 14:37:04 EDT
commit 737094cd27afe1a15c30ea69167347938b21b072
Comment 5 Dafna Ron 2012-08-12 06:58:02 EDT
verified  for UI side only on si13.2 - UI selection shows only relevant versions. 
fix for Bug 843502 was not merged so we cannot create V2 storage domain.

Note You need to log in before you can comment on or make changes to this bug.