Bug 84266 - dns boot command line info not used fully (and a fix?)
dns boot command line info not used fully (and a fix?)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-13 15:14 EST by Matthew Miller
Modified: 2008-01-17 12:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:50:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2003-02-13 15:14:56 EST
If one specifies "dns" on the command line, this makes it into the second-stage
installer, but isn't shown in the *first* stage (in the loader) if one is doing
a network install. The culprit seems to be at the beginning of 
setupNetworkDeviceConfig in net.c -- if loaderData->ipinfo_set is 0, the
function returns right away. This check seems unnecessary, as the individual
bits of data each get their own if statement later -- and removing it makes
everything work perfectly, as far as I can tell.
Comment 1 Jeremy Katz 2003-02-13 17:37:54 EST
Are you specifying your ip on the command line?  Essentially, to get any of the
network information to take effect, you need to specify the ip as well otherwise
we throw it out as invalid.
Comment 2 Matthew Miller 2003-02-13 17:49:21 EST
No, I'm not. And I don't want to. :) In fact, perhaps this bug should be changed
to: "Don't throw out dns information from the command line just because ip isn't
set". :)

Most people setting up machines here don't know the campus DNS servers off the
top of their heads, so it's extremely useful to have the information pre-filled.
With earlier versions, I patched anaconda to have them hardcoded, but that's
both a pain and ugly. So I want to specify them on the command line in 
isolinux.cfg  -- a much more trivial change to make since all it requires is a
text editor and mkisofs.

Ideally, I'd like to be able to specify three different dns servers this way,
but I figure one thing at a time. :)
Comment 3 Matthew Miller 2003-02-15 22:02:16 EST
(I created bug #84409 for the "specify multiple servers" thing, by the way.)
Comment 4 Jeremy Katz 2003-02-17 15:30:03 EST
Okay, I guess that's good enough reasoning to convince me.  Committed something
similar to CVS
Comment 5 Matthew Miller 2003-02-19 09:21:12 EST
ipinfo_set now seems to be set in multiple places but never actually read 
(except in printLoaderDataIPINFO). Given your comment in loader.h about how you 
don't like the _set attribs, should it be completely removed?
Comment 6 Brent Fox 2003-05-25 10:50:36 EDT
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.

Note You need to log in before you can comment on or make changes to this bug.