Bug 84271 - redhat-config-samba will not allow more than one user when added with specific users.
redhat-config-samba will not allow more than one user when added with specifi...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-samba (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2003-02-13 16:06 EST by Larry Troan
Modified: 2016-04-18 05:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:30:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larry Troan 2003-02-13 16:06:23 EST
red-config-samba will not allow more than one user when added with specific users

Operating System: Red Hat 8.1 Beta 4

Details:
Server (and Generation): All

Steps to reproduce:
1) Install Red Hat 8.1 Beta 4 (grub/everything) 
2) Open a terminal and type "redhat-config-users"
3) Click "Add User" and add two users (test/test2)
4) Click File and Quit  
5) Open a terminal and type "redhat-config-samba"
6) Click "Preferences" then "Samba Users"
7) Click "Add User" and add the users you made (test/test2) and click "OK"
8) Click "Add" in the Samba Server Configuration 
9) Create Samba Share panel comes up 
10) Add "/tmp" for the Directory and enter "test" for the Description
11) Click the "Access" tab and select "Only allow access to specific users"
12) Select the two users (test/test2) and click "OK" and hit "ctrl q" to quit
13) vi /etc/samba/smb.conf and go to the end of the file
14) Notice only one user was added to the smb.conf file 
15) *NOTE* if three users were added only 2 will show (off by one) 

Is the issue reproducible? yes 

Workaround: no
----------
Action by: Bryan.Leopard
Issue Registered

ISSUE TRACKER 15647, opened as sev 3.
Comment 1 Brent Fox 2003-02-17 13:51:32 EST
Should be fixed with redhat-config-samba-1.0.4-1.  QA, please verify.
Comment 2 Larry Troan 2003-03-13 21:32:14 EST
FROM ISSUE TRACKER
Event posted 02-20-2003 07:04pm by ltroan with duration of 0.00        
Note: not fixed in pre-beta5.
Latest rev is redhat-config-samba-1.0.4-1.noarch.rpm on
Phoebe-re0219.0/i386/i386-disc1/RedHat/RPMS    
-------
Event posted 03-10-2003 12:34pm by Bryan.Leopard with duration of 0.00 
Not fixed in beta 5. Fails when adding 3 or more users (beta 5) 
Comment 3 Brent Fox 2003-03-14 11:38:25 EST
Beta 5 contained redhat-config-samba-1.0.3-1.  The latest GinGin tree contains
redhat-config-samba-1.0.4-1, which should fix the problem.
Comment 4 Larry Troan 2003-03-27 22:43:33 EST
FROM ISSUE TRACKER
Event posted 03-25-2003 03:53pm by Bryan.Leopard with duration of 0.00
Still a problem in the GM product.
Comment 5 Brent Fox 2003-05-25 10:30:07 EDT
There is a stack of 64 bugs that have been in Modified state for a long period
of time.  I am closing these as Rawhide now.  If you find that the issue is not
fixed, please reopen this report.

Note You need to log in before you can comment on or make changes to this bug.