This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 84272 - Redhat-config-samba will crash if public is in the smb.conf
Redhat-config-samba will crash if public is in the smb.conf
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-samba (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2003-02-13 16:09 EST by Larry Troan
Modified: 2016-04-18 05:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:30:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larry Troan 2003-02-13 16:09:06 EST
Redhat-config-samba will crash if public is in the smb.conf 
  
Operating System: Red Hat 8.1 Beta 4

Details:
Server (and Generation): All

Steps to reproduce:
1) Install Red Hat 8.1 Beta 4 (grub/everything) 
2) vi /etc/samba/smb.conf and go to the end of the file
3) Uncomment the example at the end of the file
4) Open a terminal and type "redhat-config-samba" and notice the
   error message
   
  Traceback (most recent call last):
  File "/usr/share/redhat-config-samba/redhat-config-samba.py", line 14, in ?
    mainWindow.MainWindow(debug_flag)
  File "/usr/share/redhat-config-samba/mainWindow.py", line 58, in __init__
    self.samba_data = sambaParser.SambaParser(self)
  File "/usr/share/redhat-config-samba/sambaParser.py", line 24, in __init__
    self.parseFile()
  File "/usr/share/redhat-config-samba/sambaParser.py", line 55, in parseFile
    token = self.createToken(line)
  File "/usr/share/redhat-config-samba/sambaParser.py", line 127, in createToken
    token = sambaToken.SambaToken(sambaToken.SambaToken.SAMBA_TOKEN_KEYVAL,
(name, value), self.parent)
  File "/usr/share/redhat-config-samba/sambaToken.py", line 20, in __init__
    raise AttributeError, value
AttributeError: ('public', 'no')

Is the issue reproducible? yes 

Workaround: no

"guest ok = yes" & "guest ok = no" works which replaces "public = yes" & "public
= no" but their smb.conf file has examples with "public = yes" & "public = no"
which might be used as a guideline for end users.
----------
Action by: Bryan.Leopard
Issue Registered

ISSUE TRACKER 15646, opened as sev 3.
Comment 1 Brent Fox 2003-02-17 13:51:38 EST
Should be fixed with redhat-config-samba-1.0.4-1.  QA, please verify.
Comment 2 David Lawrence 2003-02-27 15:51:18 EST
When commenting out the public example at the bottom of the stock smb.conf file
and then running redhat-config-samba, I get the following traceback error.

Traceback (most recent call last):
  File "/usr/share/redhat-config-samba/redhat-config-samba.py", line 20, in ?
    mainWindow.MainWindow(debug_flag)
  File "/usr/share/redhat-config-samba/mainWindow.py", line 58, in __init__
    self.samba_data = sambaParser.SambaParser(self)
  File "/usr/share/redhat-config-samba/sambaParser.py", line 24, in __init__
    self.parseFile()
  File "/usr/share/redhat-config-samba/sambaParser.py", line 55, in parseFile
    token = self.createToken(line)
  File "/usr/share/redhat-config-samba/sambaParser.py", line 127, in createToken
    token = sambaToken.SambaToken(sambaToken.SambaToken.SAMBA_TOKEN_KEYVAL,
(name, value), self.parent)
  File "/usr/share/redhat-config-samba/sambaToken.py", line 20, in __init__
    raise AttributeError, value
AttributeError: ('only guest', 'yes')

If I change it to 

    guest only = yes

then it will load fine. According to the smb.conf man page 'only guest' is a
synonym to 'guest only' and should be accepted as a valid directive.
Comment 3 Brent Fox 2003-03-21 11:48:25 EST
Should be fixed in redhat-config-samba-1.0.4-2, built in dist-3.0E.
Comment 4 Brent Fox 2003-05-25 10:30:09 EDT
There is a stack of 64 bugs that have been in Modified state for a long period
of time.  I am closing these as Rawhide now.  If you find that the issue is not
fixed, please reopen this report.

Note You need to log in before you can comment on or make changes to this bug.