Bug 842750 - [RHEV] Sanlock daemon can not be stopped running service sanlock stop because lockspaces still exist.
[RHEV] Sanlock daemon can not be stopped running service sanlock stop because...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sanlock (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: David Teigland
Haim
storage
:
Depends On:
Blocks: 800588
  Show dependency treegraph
 
Reported: 2012-07-24 10:11 EDT by Leonid Natapov
Modified: 2012-09-23 11:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-23 11:05:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (1.08 MB, application/octet-stream)
2012-07-24 10:11 EDT, Leonid Natapov
no flags Details

  None (edit)
Description Leonid Natapov 2012-07-24 10:11:25 EDT
Created attachment 600036 [details]
logs

Sanlock daemon can not be stopped running 'service sanlock stop' because lockspaces still exist. We need to take care of the lockspaces and remove them  upon stopping sanlock daemon or forcibly shut down the sanlock daemon which will automatically remove any remaining lockspaces.


logs attached
Comment 2 David Teigland 2012-09-20 17:17:29 EDT
Can we close this bz?  I don't think this is a bug.
Comment 3 Leonid Natapov 2012-09-23 11:05:09 EDT
when there are no leases sanlock service can be successfully stopped running service sanlock stop.

when there are active leases service can not be stopped which is seems to be correct behavior.
closing this bz as not a bug.

Note You need to log in before you can comment on or make changes to this bug.