Bug 842779 - Fedora 17 reboot and shutdown hang with quiet boot option
Fedora 17 reboot and shutdown hang with quiet boot option
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-24 11:13 EDT by Scott Poore
Modified: 2013-01-21 20:14 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-21 20:14:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Poore 2012-07-24 11:13:15 EDT
Description of problem:

A Fedora 17 install on a KVM guest hangs on reboot.  

sync && reboot -f  # worked
sync && poweroff -f  # worked

But, a reboot, shutdown, halt (and running those from systemctl) results in hang.   I have waited for more than 5 minutes several times and 20+ minutes another.

I noticed this on both the original and clone of the guest.  I've used clones to reproduce and test some cases here.

As far as I can see, removing the quiet boot option fixes my problem.

Version-Release number of selected component (if applicable):
kernel-3.3.4-5.fc17.x86_64
systemd-44-17.fc17.x86_64

How reproducible:
unknown.  I'm reproducing always by cloning a vm that exhibited the problem.

Steps to Reproduce:
1.  Install F17 on KVM guest running on F16 host
2.  reboot # or shutdown or halt
Will hang here
3.  powercycle manually using virsh destroy virsh start or virt-manager options
4.  sed -i 's/ quiet//g' /etc/default/grub
5.  reboot
Will hang here
6.  powercycle manually using virsh destroy virsh start or virt-manager options
7.  reboot
Will work here
  
Actual results:
reboots, shutdowns, halts, all hang until OS booted without quiet option

Expected results:
all work with default grub options including quiet

Additional info:
Comment 1 Josh Boyer 2013-01-08 10:40:51 EST
If reboot -f and poweroff -f worked, then it isn't a kernel issue.

I'm guessing this has been fixed since you reported it, but in case it hasn't I'll forward it over to systemd.  IIRC, there were some issues with systemd/dracut and switching back to the initramfs during shutdown a long time ago.
Comment 2 Lennart Poettering 2013-01-14 15:29:23 EST
Please follow the guide at:

http://freedesktop.org/wiki/Software/systemd/Debugging#Diagnosing_Shutdown_Problems

and see if you can get more information what precisely is hanging.
Comment 3 Scott Poore 2013-01-21 20:14:34 EST
As Josh guessed this does appear to have been fixed somewhere along the line.  I can now reboot and shutdown without it hanging.  

Guess I'll go ahead and close worksforme.  

New versions:

kernel-3.3.4-5.fc17.x86_64
systemd-44-23.fc17.x86_64


I also saw it work through with systemd-44-8.fc17.x86_64. So, maybe it was something I upgraded on the host between seeing this and now.

Anyway, I'll close this out as it's working now.

Thanks,
Scott

Note You need to log in before you can comment on or make changes to this bug.