Bug 842783 - After xorg-family update kwin crashes after logout
After xorg-family update kwin crashes after logout
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-24 11:26 EDT by Martin Kho
Modified: 2012-07-25 09:25 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-25 09:25:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Krash Handler output of kwnin crash (4.55 KB, application/octet-stream)
2012-07-24 11:26 EDT, Martin Kho
no flags Details

  None (edit)
Description Martin Kho 2012-07-24 11:26:07 EDT
Created attachment 600055 [details]
Krash Handler output of kwnin crash

Description of problem:
kwin crashes after log out / reboot in combination with the nouveau-driver. This starts happening after an ABI rebuild of xorg-server and drivers [1] 

[1] http://lists.fedoraproject.org/pipermail/test/2012-July/109057.html

Version-Release number of selected component (if applicable):
* kde-workspace-4.8.97-2.fc18.x86_64
* xorg-x11-drv-nouveau-1.0.1-3.fc18.x86_64
* xorg-x11-server-Xorg-1.12.99.902-1.20120717.fc18.x86_64

How reproducible:
Since the update kwin didn't crash only once. I always reboot at the end of the day to Fedora 17. So mostly always.

Steps to Reproduce:
1. Log out of a kde rawhide install (upgraded fedora 17 liveCD)
2. Krash handler catches the crash
3.
  
Actual results:
kwin crashes, but everything works fine when de dialog box is closed.

Expected results:
kwin doesn't crash

Additional info:
Krash handler catched the crash, but IMHO this is a typical rawhide / development issue. Wrong? Note: the report was only rated with three stars. I suppose because some debuginfo packages were not available.
Comment 1 Rex Dieter 2012-07-24 11:33:30 EDT
It's crashing in the driver,

Thread 1 (Thread 0x7fc9c9f81880 (LWP 899)):
[KCrash Handler]
#5  0x00007fc9bc5cea61 in nv30_vbo_validate () from /usr/lib64/dri/nouveau_dri.so
#6  0x00007fc9bc5eedb3 in nv30_state_validate () from /usr/lib64/dri/nouveau_dri.so
#7  0x00007fc9bc5ccea8 in nv30_clear () from /usr/lib64/dri/nouveau_dri.so
#8  0x00007fc9bc807a6e in st_Clear () from /usr/lib64/dri/nouveau_dri.so
#9  0x000000399b2bfedc in KWin::SceneOpenGL::paintBackground(QRegion) () from /lib64/libkdeinit4_kwin.so
Comment 2 Martin Kho 2012-07-25 08:52:22 EDT
Hi,

Hmmm ... The mass rebuild seems to have 'solved' the crash. So please close this report.


Martin Kho
Comment 3 Kevin Kofler 2012-07-25 09:25:33 EDT
So it looks like something just needed a rebuild for an ABI change.

Note You need to log in before you can comment on or make changes to this bug.