Bug 842820 - wine does not populate prefix with WINEARCH=win32
wine does not populate prefix with WINEARCH=win32
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-24 12:18 EDT by Pavel Rosenboim
Modified: 2012-12-20 10:55 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:55:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Rosenboim 2012-07-24 12:18:34 EDT
Description of problem:
On x86_64 install, with WINEARCH=win32, wine does not populate wine prefix. It creates prefix with few empty directories only.

Version-Release number of selected component (if applicable):
wine-1.5.8, wine-1.5.9

How reproducible:
Always

Steps to Reproduce:
1. run WINEARCH=win32 wineboot -u
2.
3.
  
Actual results:
Invalid prefix created.

Expected results:
Create working prefix.

Additional info:
Works fine with wine compiled from source as described in http://wiki.winehq.org/Wine64
Comment 1 Andreas Bierfert 2012-07-25 11:08:14 EDT
Please post a list of wine packages you have installed on your system.
Comment 2 Pavel Rosenboim 2012-07-25 14:45:45 EDT
wine-tahoma-fonts-1.5.9-1.fc17.noarch
wine-tahoma-fonts-system-1.5.9-1.fc17.noarch
wine-twain-1.5.9-1.fc17.x86_64
wine-core-1.5.9-1.fc17.i686
wine-pulseaudio-1.5.9-1.fc17.x86_64
wine-cms-1.5.9-1.fc17.i686
wine-courier-fonts-1.5.9-1.fc17.noarch
wine-ldap-1.5.9-1.fc17.i686
wine-capi-1.5.9-1.fc17.x86_64
wine-marlett-fonts-1.5.9-1.fc17.noarch
wine-desktop-1.5.9-1.fc17.noarch
wine-alsa-1.5.9-1.fc17.i686
wine-common-1.5.9-1.fc17.noarch
wine-wow-1.5.9-1.fc17.x86_64
wine-fonts-1.5.9-1.fc17.noarch
wine-openal-1.5.9-1.fc17.i686
wine-ldap-1.5.9-1.fc17.x86_64
wine-small-fonts-1.5.9-1.fc17.noarch
wine-sysvinit-1.5.9-1.fc17.noarch
wine-pulseaudio-1.5.9-1.fc17.i686
wine-filesystem-1.5.9-1.fc17.noarch
wine-openal-1.5.9-1.fc17.x86_64
wine-system-fonts-1.5.9-1.fc17.noarch
wine-twain-1.5.9-1.fc17.i686
wine-ms-sans-serif-fonts-1.5.9-1.fc17.noarch
wine-capi-1.5.9-1.fc17.i686
wine-systemd-1.5.9-1.fc17.noarch
wine-1.5.9-1.fc17.x86_64
wine-mono-0.0.4-7.fc17.noarch
wine-core-1.5.9-1.fc17.x86_64
wine-symbol-fonts-1.5.9-1.fc17.noarch
wine-cms-1.5.9-1.fc17.x86_64
wine-alsa-1.5.9-1.fc17.x86_64
Comment 3 Andreas Bierfert 2012-07-26 13:42:29 EDT
Could you install the wine meta package + deps and try with WINEARCH=win32 WINEPREFIX=~/win32 winecfg

I cannot reproduce this here with.
Comment 4 Pavel Rosenboim 2012-07-26 17:33:17 EDT
Did it on another machine, that didn't have wine installed, got same result.
Comment 5 Michael Cronenworth 2012-08-18 14:38:02 EDT
I see the same problem:

$ rpm -q wine
wine-1.5.9-1.fc17.x86_64
$ rm -rf wine32test/
$ mkdir wine32test
$ WINEARCH=win32 WINEPREFIX=/home/michael/local/wine32test winecfg
wine: WINEARCH set to win32 but '/home/michael/local/wine32test' is a 64-bit installation.
Comment 6 Clodoaldo Pinto Neto 2012-08-26 11:10:26 EDT
I can confirm it:

$ rpm -q wine
wine-1.5.11-1.fc17.x86_64
$ rm -rf wine32bit/
$ mkdir wine32bit
$ WINEARCH=win32 WINEPREFIX=/home/cpn/wine32bit winecfg
wine: WINEARCH set to win32 but '/home/cpn/wine32bit' is a 64-bit installation.
Comment 7 Clodoaldo Pinto Neto 2012-09-15 11:56:46 EDT
Still same result with wine-1.5.12-2.fc17.x86_64
Comment 8 Troy Volin 2012-10-29 14:36:04 EDT
Hi. I don't understand why you guys are having a hard time recreating this.
Meanwhile, I think I know what the problem is.
Here's the output I get:
[tvolin@jumbo ssl]$ rm -r /home/tvolin/mywine32
[tvolin@jumbo ssl]$ WINEARCH=win32 WINEPREFIX=/home/tvolin/mywine32 winecfg
wine: created the configuration directory '/home/tvolin/mywine32'
wine: cannot find L"C:\\windows\\system32\\wineboot.exe"
err:process:start_wineboot failed to start wineboot, err 2
err:xrandr:xrandr12_init_modes Failed to get output info.
WARNING: couldn't connect to: /tmp/keyring-5iBCco/pkcs11: No such file or directory
err:xrandr:xrandr12_init_modes Failed to get output info.

So I went looking for wineboot.
[tvolin@jumbo ssl]$ find /usr/lib/wine /usr/lib64/wine -name \*wineboot\*
/usr/lib/wine/fakedlls/wineboot.exe
/usr/lib64/wine/fakedlls/wineboot.exe
/usr/lib64/wine/wineboot.exe.so

We are missing /usr/lib/wine/wineboot.exe.so
It is the *only* file present in /usr/lib64/wine which is *not* present in /usr/lib/wine.

PAVEL - when you compile from source and it works fine, is there a /usr/lib/wine/wineboot.exe.so created? (obviously /usr/local or whatever your build output is)

(I am on FC16 x86_64, wine-1.5.13-1.fc16)
Comment 9 Michael Cronenworth 2012-10-29 14:45:37 EDT
Troy,

This does seem to solve it.

Andreas,

Do you think we could move wineboot.exe.so from wine-wow to wine-core?
Comment 10 Pavel Rosenboim 2012-10-29 16:33:58 EDT
Yes.

I unpacked wineboot.exe.so from x86 wine-wow and placed it in /usr/lib/wine and it solves the problem.
Comment 11 Andreas Bierfert 2012-10-29 17:49:53 EDT
Hm, thanks for looking into this further. Seems this was leftover from moving wineboot...
Comment 12 Troy Volin 2012-10-29 23:10:58 EDT
Ah. I see.
So when I did "yum install wine" it pulled in both i686 and x86_64 flavors of several wine-splat packages.
I just tried "yum install wine.i686" and found that the only thing it was going to pull in (which I didn't already get from installing "wine" (which was wine.x86_64) was "wine-wow.i686".
wine.x86_64 conflicts with wine-wow.i686.
I guess that's the problem.
Forcing it works fine.
Thanks guys.
Comment 13 Troy Volin 2012-10-29 23:25:32 EDT
Correction. I extracted it, as Pavel did above.
/usr/bin/wineserver from wine-wow.i686 is not the same as /usr/bin/wineserver from wine-wow.x86_64 (no surprise there). So I didn't force-replace it.
(The /usr/bin/wine from wine-wow.i686 is the same as my existing one from wine-core.i686, though it seems superfluous and not parallel with wine-wow.x86_64.)

No suggestion about what the "ideal state" is when it comes to /usr/bin/wineserver 32/64.
Meanwhile, I'm happily working around it.
Comment 14 Fedora Update System 2012-10-30 11:57:00 EDT
mingw-wine-gecko-1.8-1.fc18, wine-mono-0.0.8-1.fc18, wine-1.5.16-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-15124/wine-mono-0.0.8-1.fc18,mingw-wine-gecko-1.8-1.fc18,wine-1.5.16-1.fc18
Comment 15 Fedora Update System 2012-10-30 12:02:16 EDT
mingw-wine-gecko-1.8-1.fc17, wine-mono-0.0.8-1.fc17, wine-1.5.16-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-15138/mingw-wine-gecko-1.8-1.fc17,wine-mono-0.0.8-1.fc17,wine-1.5.16-1.fc17
Comment 16 Fedora Update System 2012-10-30 12:03:15 EDT
wine-1.5.16-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-15135/wine-1.5.16-1.fc16
Comment 17 Fedora Update System 2012-10-30 16:17:20 EDT
Package mingw-wine-gecko-1.8-1.fc18, wine-mono-0.0.8-1.fc18, wine-1.5.16-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mingw-wine-gecko-1.8-1.fc18 wine-mono-0.0.8-1.fc18 wine-1.5.16-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15124/wine-mono-0.0.8-1.fc18,mingw-wine-gecko-1.8-1.fc18,wine-1.5.16-1.fc18
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2012-12-20 10:55:57 EST
mingw-wine-gecko-1.8-1.fc18, wine-mono-0.0.8-1.fc18, wine-1.5.16-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.