Bug 84289 - no network config during install; no pcmcia driver in /proc/devices
no network config during install; no pcmcia driver in /proc/devices
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
8.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-13 20:33 EST by dsamperi
Modified: 2015-01-04 17:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 03:30:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dsamperi 2003-02-13 20:33:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
The installation process in Custom mode does not present the form
used to configure my network, and my PCMCIA devices are not detected.
I'm trying to upgrade my laptop (Toshiba 4025 CDT) from Red Hat 6.1 to
Red Hat 8.0. My PCMCIA cards have worked fine under Red Hat 6.1 for
several years, using David Hinds PCMCIA software. Clearly the problem
is due to the way the DHinds software is packaged with Red Hat 8.0.

If I try to manually start the cardmgr after the install completes I
get the error message (in /var/log/messages) "no pcmcia driver in
/proc/drivers" and cardmgr terminates. 

Note that I also tried installing Red Hat 7.2 on this hardware and in this case
things went a little better: Although the installer still
didn't recognize my hardware I was able to start /sbin/cardmgr manually. and I
was able to bring up my network (manually) using /sbin/ifconfig.

Note that it seems that the later the version of Red Hat that I try
to install, the greater the number of problems that I encounter. Seems
like the installer design does not consider backwards compatibility very important.

The PCMCIA cards that I'm using are a 3Com 56K modem card and
a Xircom CE3B-100BTX ethernet card.

By the way, I posted this bug on the Official Red Hat support site,
and the response I received was to post it here. What is the relationship
between that site (comes with purchase of Red Hat 8.0)
and this one. Although I was not told explicitly I assume since I
was redirected that this kind of problem is "not supported" by RH.

Would it be a good idea for me to try to install David Hinds'
PCMCIA software by hand?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Red Hat 8.0 (or 7.2) on Toshiba 4025 CDT with PCMCIA cards
2.
3.
    

Actual Results:  Doesn't present network configuration form.
Doesn't recognize PCMCIA cards at all.
/sbin/cardmgr will not start.

Expected Results:  Should recognize my hardware and automatically permit me to
configure my network.

Additional info:
Comment 1 dsamperi 2003-02-16 09:57:58 EST
Tried commenting out some lines in /etc/pcmcia/config.opts that were
causing problems and now when I try to start /sbin/cardmgr I get
the messages "no function bindings" for the first line of
config.opts (no matter what is on this line).

If I try /sbin/modprobe xirc2ps_cs irq_list=7, I get the
messages in /var/log/messages: "ds.o: no socket drivers loaded"

My laptop is a bit old. Can you recommend laptops that work well
with Red Hat 8.0?

Note You need to log in before you can comment on or make changes to this bug.