Bug 842905 - user_u crontab_t autofs .viminfo
user_u crontab_t autofs .viminfo
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.5
All Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Michal Trunecka
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-24 17:30 EDT by Sol Jerome
Modified: 2014-09-30 19:33 EDT (History)
4 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-160.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:26:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sol Jerome 2012-07-24 17:30:52 EDT
Description of problem:

A user_u selinux user is unable to write to .viminfo via crontab.


Version-Release number of selected component (if applicable):

selinux-policy-3.7.19-155.el6_3.noarch

How reproducible:

always

Steps to Reproduce:
1. automount user's home directory
2. setsebool -P use_nfs_home_dirs=1
3. try to edit crontab with EDITOR=vim
  
Actual results:

Crontab is edited successfully, with the following AVC:

type=AVC msg=audit(1343164641.420:12541): avc:  denied  { search } for  pid=4752 comm="vim" name="/" dev=autofs ino=10361 scontext=user_u:user_r:crontab_t:s0 tcontext=system_u:object_r:autofs_t:s0 tclass=dir

Expected results:

User should be able to write to ~/.viminfo.

Additional info:

# echo "avc:  denied  { search } for  pid=4752 comm="vim" name="/" dev=autofs ino=10361 scontext=user_u:user_r:crontab_t:s0 tcontext=system_u:object_r:autofs_t:s0 tclass=dir" | audit2why 
avc:  denied  { search } for  pid=4752 comm=vim name=/ dev=autofs ino=10361 scontext=user_u:user_r:crontab_t:s0 tcontext=system_u:object_r:autofs_t:s0 tclass=dir

        Was caused by:
                Missing type enforcement (TE) allow rule.

                You can use audit2allow to generate a loadable module to allow this access.
Comment 2 Daniel Walsh 2012-08-03 07:47:39 EDT
Do you have NFS Home dirs?
Comment 3 Sol Jerome 2012-08-03 08:58:22 EDT
(In reply to comment #2)
> Do you have NFS Home dirs?

Yes. They are mounted via autofs.
Comment 4 Daniel Walsh 2012-08-13 16:23:43 EDT
This is currently allowed in F18.
Comment 5 Miroslav Grepl 2012-08-20 03:39:50 EDT
Will backport it.
Comment 8 errata-xmlrpc 2013-02-21 03:26:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0314.html

Note You need to log in before you can comment on or make changes to this bug.