Bug 842906 - brasero video disc burning not supported, shows ugly error
brasero video disc burning not supported, shows ugly error
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: brasero (Show other bugs)
7.0
All Linux
unspecified Severity low
: rc
: 7.1
Assigned To: David King
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-24 17:36 EDT by Mark Gordon
Modified: 2015-09-08 16:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-08 16:14:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 719991 None None None Never

  None (edit)
Description Mark Gordon 2012-07-24 17:36:03 EDT
Description of problem:

If you attempt to burn a video disc project in brasero, you get an obscure error message.

Version-Release number of selected component (if applicable):
3.4.1-1.el.7

How reproducible:
100%

Steps to Reproduce:
1. Run brasero
2. Click the "Video Project / Create a video DVD or an SVCD" button.
3. Click the "+" button
4. In the file browser, select a video file.  I've been using /usr/share/gnome/help/evince/C/figures/synctex_screencast.ogv, but I get similar results with other files.
5. Project -> Burn...
  
Actual results:
"All required applications and libraries are not installed.

Please install the following manually and try again:
mplex (GStreamer plugin)
ffenc_mp2 (GStreamer plugin)
ffenc_ac3 (GStreamer plugin)
ffenc_mpeg2video (GStreamer plugin)
vcdimager (application)."

Expected results:
Good question; I was quite skeptical about whether it would work.  Perhaps the real question is how exactly it could be failing better.  The error message was probably written for end-users with the technical expertise to find "bad" apps and GStreamer plugins but I'm not sure it's a great idea for us to offer our users that advice, at the very least because it's not terribly user-friendly advice.  Might it be better to present a different error message? Dim and disable the Burn... option iff it's not supported?  Are there third-party vendors from whom users could buy codecs, in which case we could direct them to those vendors? 

Additional info:
Google suggests that Ubuntu users had similar problems.
Comment 8 Jiri Koten 2015-05-13 08:44:32 EDT
Still reproducible in brasero-3.12.0-1.el7, it asks for manual install instead of packagekit.
Comment 9 Matthias Clasen 2015-09-08 16:14:20 EDT
It seems unlikely that we'll get a fix for this, unless it gets fixed upstream first.

Note You need to log in before you can comment on or make changes to this bug.