Bug 842921 - Clarify effect of Passivation configuration option
Clarify effect of Passivation configuration option
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Grid 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity low
: ---
: 6.0.1
Assigned To: Misha H. Ali
ecs-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-24 19:03 EDT by Sanne Grinovero
Modified: 2012-09-19 23:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Instance Name: Not Defined Build: CSProcessor Builder Version 1.4 Build Filter: null Build Name: Build Date: 15-06-2012 10:17:05
Last Closed: 2012-09-19 23:48:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sanne Grinovero 2012-07-24 19:03:47 EDT
Paragraph 8.2.6.1 currently reads:

8.2.6.1. The Cache Loader and Cache Passivation
In JBoss Data Grid, a cache loader can be used to enforce the passivation of entries and to activate eviction in a cache. Whether passivation mode or activation mode are used, the configured cache loader both reads from and writes to the data store.
When passivation is enabled in JBoss Data Grid, after the modification, addition or removal of an element is carried out the cache loader steps in to persist the changes in the store. 


I think it's very confusing and the second sentence is likely wrong. We would need to clarify the difference between options passivation="true" or passivation="false". It would help to refer to table Table 10.1 or Table 10.2 as well.
Comment 1 Misha H. Ali 2012-08-05 20:57:46 EDT
Emailed Sanne for clarification about the first part of this comment.

To address ref to table 10.1/table 10.2 comment, adding links to tables outlining what occurs when passivation is on and off.
Comment 2 Sanne Grinovero 2012-08-06 05:29:42 EDT
To clarify my first comment, the culprit of my doubt is in the wording
"When passivation is enabled [..] after modification, addition or removal [..] the cacheloader steps in to persist the changes"

While reading - especially the first sentence:

https://docs.jboss.org/author/display/ISPN/CacheLoaders#CacheLoaders-cachepassivation

that seems to be the behaviour when a CacheLoader is DISABLED; when it is enabled the cacheloader should step in on an eviction event, not any other modification.

I'm not sure that a CacheLoader doesn't trigger *also* on a modification; asking someone on the Infinispan team to confirm this.
Comment 3 Mircea Markus 2012-08-06 07:20:47 EDT
@Sanne +1, the behaviour described in the sentence you quoted is incorrect. The sentence should state "When the passivation is *disabled* .. "
Comment 4 Misha H. Ali 2012-08-06 23:46:36 EDT
Apologies, Sanne, I was looking at the first sentence of the first paragraph from the content you posted in the original post, not the first sentence of the second paragraph. Thanks for the clarifications, both of you!
Comment 5 Misha H. Ali 2012-08-07 19:38:07 EDT
Change made, will move this bug to ON_QA once it appears on the stage for verification.

Note You need to log in before you can comment on or make changes to this bug.