Bug 842977 - mysql shuts itself down approx every 24 hrs
mysql shuts itself down approx every 24 hrs
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Rob Millner
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 04:07 EDT by Jon
Modified: 2015-05-14 18:56 EDT (History)
3 users (show)

See Also:
Fixed In Version: devenv_1913
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 16:42:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon 2012-07-25 04:07:07 EDT
Approximately between 12:15 and 13:15 EDT every day mysql appears to shut itself down.


Version-Release number of selected component (if applicable): mysql-5.1


How reproducible: Always on my app


Steps to Reproduce:
1. Just wait :)


Additional info: This is the output that appears in the log files each day:
120724 13:16:20 [Note] /usr/libexec/mysqld: Normal shutdown

120724 13:16:20 [Note] Event Scheduler: Purging the queue. 0 events
120724 13:16:20  InnoDB: Starting shutdown...
120724 13:16:20  InnoDB: Shutdown completed; log sequence number 0 44233
120724 13:16:20 [Note] /usr/libexec/mysqld: Shutdown complete

120724 13:16:20 mysqld_safe mysqld from pid file /var/lib/stickshift/90146f1adc384f7e82fdf0214b92f2bc//mysql-5.1/pid/mysql.pid ended

My app is at lab-iksystems. Please let me know if I can provide any further info for you.
Comment 1 Jon 2012-07-25 14:03:39 EDT
MySQL shutdown again at 13:50 today:

120725 13:50:29 [Note] /usr/libexec/mysqld: Normal shutdown

120725 13:50:29 [Note] Event Scheduler: Purging the queue. 0 events
120725 13:50:29  InnoDB: Starting shutdown...
120725 13:50:31  InnoDB: Shutdown completed; log sequence number 0 44233
120725 13:50:31 [Note] /usr/libexec/mysqld: Shutdown complete

120725 13:50:31 mysqld_safe mysqld from pid file /var/lib/stickshift/90146f1adc384f7e82fdf0214b92f2bc//mysql-5.1/pid/mysql.pid ended

Jon
Comment 4 Rob Millner 2012-07-25 19:58:05 EDT
The root cause of the issue was found and will be corrected in the next release.

A workaround was put in place on your mysql gear which should prevent shutdown until the next release is put into production.
Comment 7 Johnny Liu 2012-07-30 04:17:54 EDT
Verified this bug on devenv_1920, and PASSED.
Comment 8 Jon 2012-08-07 09:30:24 EDT
Hi guys,

just to mention that this issue has re-occured on my box. Is this due to a new release overwriting your update?

Thanks,

Jon
Comment 9 Rob Millner 2012-08-07 13:13:56 EDT
Hey Jon,

Sorry about that - the permanent fix got delayed going to production.   It should happen in the next few days.

Hitting the following URL will give your mysql instance 14 more days before the idle gear detection sees it again.

http://90146f1adc-iksystems.rhcloud.com/

My apologies again for the hassle.

    Cheers,
    Rob
Comment 10 Rob Millner 2012-08-07 13:15:20 EDT
...forgot to mention, I've already re-awakened it.
Comment 11 Jon 2012-08-07 16:32:47 EDT
lol - cheers Rob. Apache on the web gear had gone down as well - not sure if that was related to hitting that URL, but I've started it back up again. I'll keep an eye on it next couple of days...

Thanks again,

Jon

Note You need to log in before you can comment on or make changes to this bug.