Bug 84298 - slow display of text using lots of CPU
slow display of text using lots of CPU
Status: CLOSED DUPLICATE of bug 83472
Product: Red Hat Linux
Classification: Retired
Component: gnome-terminal (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Depends On:
  Show dependency treegraph
Reported: 2003-02-14 01:20 EST by Stephen John Smoogen
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:51:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Stephen John Smoogen 2003-02-14 01:20:49 EST
Description of problem:

Have noticed this with all displays (xterm, konsole, gnome-terminal) but most
have improved in speed greatly (possibly fixes in other related libraries).

ls seems to have improved in speed with the rawhide of 20030213, but
it still pegs the CPU at 100% for 6-7 seconds. The speed of xterm has
improved greatly. Here is my current test. Copy all of
rawhide/i386/RedHat/RPMS into a directory and then cd into it.

time ls -l in gnome-terminal/konsole/xterm 

real    0m0.753s
user    0m0.260s
sys     0m0.000s

real    0m2.050s
user    0m0.100s
sys     0m0.100s

real    0m6.082s
user    0m0.040s
sys     0m0.040s

unaliasing ls did not change things. There are also general slow 
displays in most of the 'layout' when working in gnome-terminal.
How can I debug this furhter?
Comment 1 Havoc Pennington 2003-02-14 12:06:28 EST

*** This bug has been marked as a duplicate of 83472 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:51:47 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.