Bug 842986 - Wrong boot protocol for non-VLANed non-bridged networks
Wrong boot protocol for non-VLANed non-bridged networks
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Moti Asayag
Meni Yakove
Network
:
Depends On: 843498
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 04:32 EDT by Igor Lvovsky
Modified: 2012-12-04 14:58 EST (History)
11 users (show)

See Also:
Fixed In Version: si13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 14:58:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor Lvovsky 2012-07-25 04:32:02 EDT
Description of problem:

Attach non-VLANed non-bridged network to interface and set boot protocol to static with IP and netmask.
The setupNetwork will get the parameters and action will be performed successfully.
But, if we will open edit network screen again, we will see IP and netmask fields greyed-out (with proper parameters inside) and boot protocol will back to None

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 GenadiC 2012-07-25 07:54:58 EDT
Another scenario: When you configure VLAN Network over the bond, the boot protocol will be None as well, even when you change the protocol to DHCP or static
Comment 2 Igor Lvovsky 2012-07-25 11:03:50 EDT
It happens only on bridgeless (VLAN or non-VLAN) network, without any relation to the bond
Comment 3 Igor Lvovsky 2012-07-25 11:05:02 EDT
According to Moti the cause of this is absent of 'cfg' field in getVdsCaps for bridgeless networks.
Comment 7 Meni Yakove 2012-08-05 03:58:24 EDT
Verified on vdsm-4.9.6-26.0.el6_3.x86_64.

Note You need to log in before you can comment on or make changes to this bug.