This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 842992 - Creating custom software channels starting with RHN will fail claiming admin rights are needed (even if admin)
Creating custom software channels starting with RHN will fail claiming admin ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
541
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Tomas Lestach
Lukas Pramuk
:
Depends On:
Blocks: sat560-blockers
  Show dependency treegraph
 
Reported: 2012-07-25 04:54 EDT by Bart van den Heuvel
Modified: 2013-10-01 17:51 EDT (History)
3 users (show)

See Also:
Fixed In Version: spacewalk-java-1.8.123-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:51:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bart van den Heuvel 2012-07-25 04:54:40 EDT
Description of problem:
In the WEBui: When creating a software channel in Satellite with a Channel name that starts with RHN or a label that starts with RHN.
You get a message that you need admin privileges and it fails to create the channel. If you use the same names but end with RHN, or leave the RHN out (Custom tools RHN or custom-tools-rhn) it will work right away.

The message is false as doing it is admin


Version-Release number of selected component (if applicable):
Tested on 5.4.1 but also 5.4.0 

How reproducible:
Login as admin
select Channels
select manage software channels
select create new channel
Fill in the field:
 - name: RHN custom tools
 - label: rhn-custom-tools
 - other fields don't matter, select a base channel, add description
select Create Channel

This message will appear:
Red Hat Channels require admin privileges


Steps to Reproduce:
1. Login as admin
2. select Channels
3. select manage software channels
4. select create new channel
5. Fill in the field:
 - name: RHN custom tools
 - label: rhn-custom-tools
 - other fields don't matter, select a base channel, add description
6. select Create Channel

This message will appear:
Red Hat Channels require admin privileges
  
Actual results:
Channel not created, false message about privileges is displayed

Expected results:
Creation of a Software channel or if we don't allow names/labels to start with RHN or rhn we need to put that in a clear message.

Additional info:
If the RHN in the name and the rhn is appended instead of in front it does work.
Comment 1 Tomas Lestach 2012-08-02 11:48:51 EDT
fixed in upstream ...

spacewalk.git: bd56cf2136f10edf58c6ffc2a282dbcf4bb7b260
Comment 3 Lukas Pramuk 2013-05-28 06:54:49 EDT
VERIFIED in spacewalk-java-1.9.83-35.el6sat

Verified manually by steps to reproduce in comment #0.
Also checked behavior when updating and cloning channel.
Comment 4 Clifford Perry 2013-10-01 17:51:17 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.