Bug 84300 - normal xterm needs an icon
normal xterm needs an icon
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: FutureFeature, MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-14 01:23 EST by Stephen John Smoogen
Modified: 2007-03-27 00:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-11 06:19:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen John Smoogen 2003-02-14 01:23:04 EST
Description of problem:

xterm needs to be linked against an icon. Currently it has the default page
icon, but should probably use the gnome-xterm.png icon. I am not sure where this
gets linked so put it in redhat-artwork.
Comment 1 Havoc Pennington 2003-02-18 14:41:44 EST
The icons are set by the apps themselves, so xterm code would require modification. 
Comment 2 Mike A. Harris 2003-02-18 18:04:38 EST
This is a feature enhancement/modification that the xterm author (Thomas Dickey)
would have to make to upstream sources first and then get integrated into
XFree86, and then into Red Hat Linux via upstream.

If you would like to see this enhancement made, please email the xterm
author directly, or the xfree86@xfree86.org mailing list to request the
feature.

Closing enhancement request as UPSTREAM
Comment 3 Thomas E. Dickey 2003-02-21 16:01:17 EST
actually not.  It's a customization that Redhat could easily make without compiling 
xterm.  It would be done by setting the iconPixmap resource, e.g.,
   *iconPixmap: terminal
Although the "terminal" pixmap is in the standard distribution, I don't recall seeing
it used for a very long time (X11R4).  A more suitable choice would be what KDE
uses - I don't know the name of that file.
Comment 4 Stephen John Smoogen 2003-02-21 19:53:29 EST
Ok this looks like a build patch then..
Comment 5 Mike A. Harris 2003-04-11 06:19:15 EDT
Closing WONTFIX

Note You need to log in before you can comment on or make changes to this bug.