Bug 843010 - subscription-manager release --list => Broken pipe exception
subscription-manager release --list => Broken pipe exception
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
x86_64 Linux
unspecified Severity medium
: beta
: 7.0
Assigned To: candlepin-bugs
Entitlement Bugs
:
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2012-07-25 06:01 EDT by Milan Falešník
Modified: 2013-01-30 08:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-30 08:37:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/rhsm/rhsm.log of this operation in "Steps to reproduce" (17.33 KB, application/octet-stream)
2012-07-25 06:01 EDT, Milan Falešník
no flags Details

  None (edit)
Description Milan Falešník 2012-07-25 06:01:48 EDT
Created attachment 600254 [details]
/var/log/rhsm/rhsm.log of this operation in "Steps to reproduce"

Description of problem:
- When trying to get list of releases (subscription-manager release --list), operation fails with uncaught exception "Broken pipe"

Version-Release number of selected component (if applicable):
subscription-manager-0.99.19-1.el6.x86_64

How reproducible:
Register, subscribe and try to get a list of releases.

Steps to Reproduce:
~~~~~ BEGIN ~~~~~
[root@mfalesnik-laptop rhsm]# subscription-manager register --username=<hidden>@redhat.com --password=<hidden>
The system has been registered with id: <hidden>
[root@mfalesnik-laptop rhsm]# subscription-manager subscribe --auto
Installed Product Current Status:
Product Name:           Red Hat Enterprise Linux Workstation
Status:                 Subscribed

[root@mfalesnik-laptop rhsm]# subscription-manager release --list
(32, 'Roura p\xc5\x99eru\xc5\xa1ena (SIGPIPE)')
~~~~~ END ~~~~~

Translation: "Roura p\xc5\x99eru\xc5\xa1ena" => [CZ]Roura přerušena => [EN]Broken pipe

This was before "yum repolist", but after that, result still persists.
  
Actual results:
(32, 'Roura p\xc5\x99eru\xc5\xa1ena (SIGPIPE)')

Expected results:
Some kind of fancy error report to let user know what's going on.

Additional info:
- Using internal QA account (DOC-64963 @ docspace)
- !!! Maybe SSL cert conflict with dogfood (my primary source of updates). !!!
Comment 2 RHEL Product and Program Management 2012-12-14 03:47:26 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 William Poteat 2013-01-30 08:37:29 EST
Unable to reproduce. Closing as Notabug.

Note You need to log in before you can comment on or make changes to this bug.