Bug 84302 - Radeon 7500 card not playing OpenGL games
Radeon 7500 card not playing OpenGL games
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-14 02:23 EST by SinisterBunny
Modified: 2007-04-18 12:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-12 00:16:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config File. (3.23 KB, text/plain)
2003-02-14 02:25 EST, SinisterBunny
no flags Details
XFfree86 Log file (30.63 KB, text/plain)
2003-02-15 02:50 EST, SinisterBunny
no flags Details

  None (edit)
Description SinisterBunny 2003-02-14 02:23:54 EST
Description of problem:
Radeon 7500 Mobility graphics card crashes when loading up GL games.
glxgears works fine, but as soon as tuxracer loads up past the menu it crashs X,
not a full hardware crash but just will kick back to X. Same goes for Chromium
and Quake3.
I am using the Standard RH8 X server packages.
2D works fine.



Version-Release number of selected component (if applicable):

XFree86-4.2.0-72


How reproducible:
Extremely consistent

Steps to Reproduce:
1. Open X
2.Start tuxracer/Chromium/Quake3
3.
    
Actual results:


Expected results:


Additional info:
When Hardware Acceleration is turned off in the display control panel tux will
work, but obviously very slow.
Comment 1 SinisterBunny 2003-02-14 02:25:24 EST
Created attachment 90079 [details]
XF86Config File.
Comment 2 Michael Fratoni 2003-02-15 00:08:34 EST
Using the links to create an attachment, could you please post your 
log file?
(/var/log/XFree86.0.log)
Comment 3 SinisterBunny 2003-02-15 02:50:34 EST
Created attachment 90102 [details]
XFfree86 Log file

Log File for when I loaded tux up and it crashed. Copied the log file out of
/var before reloading X
Comment 4 SinisterBunny 2003-02-24 03:42:53 EST
Anybody have any idea on this one?
Hardware, ATi Radeon mobility 7500 in a Compaq Evo N1000C laptop.
Comment 5 Mike A. Harris 2003-02-24 22:25:50 EST
Dunno, I don't have any Radeon Mobility hardware. Works fine for me on
Radeon 7500 however.  Perhaps there are some clues present though:

(II) RADEON(0): Supported additional Video Mode:
(II) RADEON(0): clock: 65.0 MHz   Image Size:  286 x 214 mm
(II) RADEON(0): h_active: 1024  h_sync: 1048  h_sync_end 1184 h_blank_end 1320
h_border: 0
(II) RADEON(0): v_active: 768  v_sync: 771  v_sync_end 777 v_blanking: 803
v_border: 0
(II) RADEON(0):  eÿP
(II) RADEON(0):  AUQ
(II) RADEON(0): Monitor name: B141XG03
(II) RADEON(0): End of DDC Monitor info


Looks like DDC probe information is getting screwed here.  Not that that
is the problem of course, but it does suggest some other bug or hardware
issue.

Please attach your kernel log from after a crash, as I'd like to see if the
CP is hanging.
Comment 6 SinisterBunny 2003-02-26 07:55:44 EST
What exaclty are you looking for? /var/log/messages?
If so, i cat'ted it before I loaded Tux and when It crashed , nothing changed,
no new entries nothing.
If its not /var/log/messages , what am I looking for and where can I find it?
Comment 7 Mike A. Harris 2003-04-12 00:16:09 EDT
tuxracer and chromium work fine for me in both Red Hat Linux 8.0 and 9 on
Radeon 7500 and other Radeon hardware.

Closing bug WONTFIX due to lack of required information.  If this problem
persists in Red Hat Linux 9, please file a bug upstream in XFree86.org
bugzilla at:  http://bugs.xfree86.org and/or discuss the issue on the
dri-devel mailing list on sourceforge.  That is the best way to get problems
resolved with 3D acceleration issues that affect video games.

Note You need to log in before you can comment on or make changes to this bug.