Bug 843075 - Crash in qr_unlink()
Crash in qr_unlink()
Status: CLOSED DUPLICATE of bug 846240
Product: GlusterFS
Classification: Community
Component: quick-read (Show other bugs)
mainline
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Raghavendra G
: Triaged
Depends On:
Blocks: 852576 858485
  Show dependency treegraph
 
Reported: 2012-07-25 10:00 EDT by Vijay Bellur
Modified: 2014-07-11 11:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 852576 (view as bug list)
Environment:
Last Closed: 2014-07-11 11:13:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijay Bellur 2012-07-25 10:00:04 EDT
Description of problem:

Found the followng backtrace in jenkins:

#0  0x00002aaaabc4f445 in qr_unlink (frame=0x2b690273b428, this=0x16d1d830, loc=0x2aaab007a120, xflag=0, xdata=0x0)
    at /opt/jenkins/jobs/glusterfs/workspace/xlators/performance/quick-read/src/quick-read.c:3338
#1  0x00002aaaabe5b22e in mdc_unlink (frame=0x2b690273ff68, this=0x16d1e900, loc=0x2aaab007a120, xflag=0, xdata=0x0)
    at /opt/jenkins/jobs/glusterfs/workspace/xlators/performance/md-cache/src/md-cache.c:1085
#2  0x00002aaaac072ad5 in io_stats_unlink (frame=0x2b690273e93c, this=0x16d1f9d0, loc=0x2aaab007a120, xflag=0, xdata=0x0)
    at /opt/jenkins/jobs/glusterfs/workspace/xlators/debug/io-stats/src/io-stats.c:1944
#3  0x00002b6902da155b in fuse_unlink_resume (state=0x2aaab007a100)
    at /opt/jenkins/jobs/glusterfs/workspace/xlators/mount/fuse/src/fuse-bridge.c:1452
#4  0x00002b6902d99bc1 in fuse_resolve_done (state=0x2aaab007a100) at /opt/jenkins/jobs/glusterfs/workspace/xlators/mount/fuse/src/fuse-resolve.c:536
#5  0x00002b6902d99c82 in fuse_resolve_all (state=0x2aaab007a100) at /opt/jenkins/jobs/glusterfs/workspace/xlators/mount/fuse/src/fuse-resolve.c:565
#6  0x00002b6902d99b8d in fuse_resolve (state=0x2aaab007a100) at /opt/jenkins/jobs/glusterfs/workspace/xlators/mount/fuse/src/fuse-resolve.c:522
#7  0x00002b6902d99c60 in fuse_resolve_all (state=0x2aaab007a100) at /opt/jenkins/jobs/glusterfs/workspace/xlators/mount/fuse/src/fuse-resolve.c:561
#8  0x00002b6902d99cf4 in fuse_resolve_continue (state=0x2aaab007a100)
    at /opt/jenkins/jobs/glusterfs/workspace/xlators/mount/fuse/src/fuse-resolve.c:581
#9  0x00002b6902d99456 in fuse_resolve_parent (state=0x2aaab007a100)
    at /opt/jenkins/jobs/glusterfs/workspace/xlators/mount/fuse/src/fuse-resolve.c:283
#10 0x00002b6902d99b66 in fuse_resolve (state=0x2aaab007a100) at /opt/jenkins/jobs/glusterfs/workspace/xlators/mount/fuse/src/fuse-resolve.c:515
#11 0x00002b6902d99c13 in fuse_resolve_all (state=0x2aaab007a100) at /opt/jenkins/jobs/glusterfs/workspace/xlators/mount/fuse/src/fuse-resolve.c:554
#12 0x00002b6902d99d2c in fuse_resolve_and_resume (state=0x2aaab007a100, fn=0x2b6902da1059 <fuse_unlink_resume>)
    at /opt/jenkins/jobs/glusterfs/workspace/xlators/mount/fuse/src/fuse-resolve.c:594
#13 0x00002b6902da165c in fuse_unlink (this=0x16cf6090, finh=0x2aaab000cc10, msg=0x2aaab000cc38)
    at /opt/jenkins/jobs/glusterfs/workspace/xlators/mount/fuse/src/fuse-bridge.c:1467
#14 0x00002b6902daf10d in fuse_thread_proc (data=0x16cf6090) at /opt/jenkins/jobs/glusterfs/workspace/xlators/mount/fuse/src/fuse-bridge.c:4189
#15 0x0000003d81c0673d in start_thread () from /lib64/libpthread.so.0
#16 0x0000003d810d44bd in clone () from /lib64/libc.so.6

Logs from the time of crash:

[2012-07-25 11:17:36.628797] W [client-rpc-fops.c:2604:client3_3_lookup_cbk] 0-patchy-client-0: remote operation failed: File name too long. Path: /_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_12345 (00000000-0000-0000-0000-000000000000)
[2012-07-25 11:17:36.628845] W [fuse-bridge.c:361:fuse_entry_cbk] 0-glusterfs-fuse: 129729: LOOKUP() /_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_12345 => -1 (File name too long)
[2012-07-25 11:17:36.700875] W [client-rpc-fops.c:2604:client3_3_lookup_cbk] 0-patchy-client-0: remote operation failed: File name too long. Path: /_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_12345 (00000000-0000-0000-0000-000000000000)
[2012-07-25 11:17:36.701054] W [client-rpc-fops.c:2604:client3_3_lookup_cbk] 0-patchy-client-1: remote operation failed: File name too long. Path: /_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_12345 (00000000-0000-0000-0000-000000000000)
[2012-07-25 11:17:36.701095] W [fuse-bridge.c:361:fuse_entry_cbk] 0-glusterfs-fuse: 129968: LOOKUP() /_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_12345 => -1 (File name too long)
[2012-07-25 11:17:49.694588] W [client-rpc-fops.c:2604:client3_3_lookup_cbk] 0-patchy-client-0: remote operation failed: File name too long. Path: /_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_12345 (00000000-0000-0000-0000-000000000000)
[2012-07-25 11:17:49.694981] W [client-rpc-fops.c:2604:client3_3_lookup_cbk] 0-patchy-client-1: remote operation failed: File name too long. Path: /_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_12345 (00000000-0000-0000-0000-000000000000)
[2012-07-25 11:17:49.695027] W [fuse-bridge.c:361:fuse_entry_cbk] 0-glusterfs-fuse: 185374: LOOKUP() /_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_12345 => -1 (File name too long)
pending frames:
frame : type(1) op(WRITE)
frame : type(1) op(WRITE)
frame : type(1) op(WRITE)
frame : type(1) op(WRITE)
frame : type(1) op(WRITE)
frame : type(1) op(WRITE)

frame : type(1) op(WRITE)
frame : type(1) op(WRITE)

patchset: git://git.gluster.com/glusterfs.git
signal received: 11
time of crash: 2012-07-25 11:17:58configuration details:
argp 1
backtrace 1
dlfcn 1
fdatasync 1
libpthread 1
llistxattr 1
setfsid 1
spinlock 1
epoll.h 1
xattr.h 1
st_atim.tv_nsec 1
package-string: glusterfs 3git
glusterfs(glusterfsd_print_trace+0x1d)[0x407f68]
/lib64/libc.so.6[0x3d810302d0]
/build/install/lib/glusterfs/3git/xlator/performance/quick-read.so(qr_unlink+0x32e)[0x2aaaabc4f445]
/build/install/lib/glusterfs/3git/xlator/performance/md-cache.so(mdc_unlink+0x243)[0x2aaaabe5b22e]
/build/install/lib/glusterfs/3git/xlator/debug/io-stats.so(io_stats_unlink+0x277)[0x2aaaac072ad5]
/build/install/lib/glusterfs/3git/xlator/mount/fuse.so(fuse_unlink_resume+0x502)[0x2b6902da155b]
/build/install/lib/glusterfs/3git/xlator/mount/fuse.so[0x2b6902d99bc1]
/build/install/lib/glusterfs/3git/xlator/mount/fuse.so[0x2b6902d99c82]
/build/install/lib/glusterfs/3git/xlator/mount/fuse.so[0x2b6902d99b8d]
/build/install/lib/glusterfs/3git/xlator/mount/fuse.so[0x2b6902d99c60]
/build/install/lib/glusterfs/3git/xlator/mount/fuse.so(fuse_resolve_continue+0x1e)[0x2b6902d99cf4]
/build/install/lib/glusterfs/3git/xlator/mount/fuse.so(fuse_resolve_parent+0x58)[0x2b6902d99456]
/build/install/lib/glusterfs/3git/xlator/mount/fuse.so[0x2b6902d99b66]
/build/install/lib/glusterfs/3git/xlator/mount/fuse.so[0x2b6902d99c13]
/build/install/lib/glusterfs/3git/xlator/mount/fuse.so(fuse_resolve_and_resume+0x31)[0x2b6902d99d2c]



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Amar Tumballi 2012-10-11 06:18:04 EDT
http://review.gluster.org/3730 posted... need comments, posted to review since july 30th, 2012
Comment 2 Niels de Vos 2014-07-11 11:13:25 EDT

*** This bug has been marked as a duplicate of bug 846240 ***

Note You need to log in before you can comment on or make changes to this bug.